none
Error 0xc8000222 installing .NET 4.0.30319 on win7-32 RRS feed

  • Question

  • Please Help....................

    Error 0xc8000222 installing .NET 4.0.30319 on win7-32

    With log

    OS Version = 6.1.7600, Platform 2
    OS Description = Windows 7 - x86 Ultimate Edition 
    CommandLine = E:\17d48784d7a8a9c3f46a51c5782437f9\\Setup.exe /x86 /x64
    Using Simultaneous Download and Install mechanism
    Operation: Installing
    Package Name = Microsoft .NET Framework 4 Client Profile Setup
    Package Version = 4.0.30319
    User Experience Data Collection Policy: Disabled
    Number of applicable items: 8
    Exe (E:\17d48784d7a8a9c3f46a51c5782437f9\SetupUtility.exe) succeeded.
    Exe Log File: dd_SetupUtility.txt
    ServiceControl operation succeeded!
    Exe (E:\17d48784d7a8a9c3f46a51c5782437f9\Windows6.1-KB958488-v6001-x86.msu) failed with 0xc8000222 - (null).
    Final Result: Installation failed with error code: (0xC8000222) (Elapsed time: 0 00:00:43).

    Saturday, March 8, 2014 6:22 AM

Answers

  • Error 0xc8000222 indicates a Windows Update issue.

    In your case, Service Pack 1 for Windows 7 is not installed.

    Please install SP1 for Windows 7 and all subsequent patches, then retry the .NET 4.0 install as follows:

    Follow these steps exactly:

    Before trying to install .NET Framework 4.0, execute this command from an ELEVATED Command Prompt provided by the .NET Framework Team:

    "This issue is likely caused by a bad ACL on assembly\tmp folder. After installing updates, the ACL propagates to installed assembly folders in both 4.0 & legacy GAC.  If those updates were installed by WU or another user, the propagated ACL will prevent install of the same assembly by the current user.

    A work around would be to reset the ACL on GAC dirs.

    for /F %D in ('dir %WINDIR%\assembly %WINDIR%\Microsoft.NET\assembly /s /b /a:d') do takeown /F %D && icacls %D /reset /T"

    After running that command, follow these steps:

    Please follow these instructions exactly:

    1. Download a fresh copy of the standalone installer for .NET Framework 4.0:

    http://www.microsoft.com/en-us/download/details.aspx?id=17718

    2. Also, clear your %temp% directory and disable your AV software.

    The %temp% directory is a reference to the Temp folder associated with the current user. To clear it, do the following:

    Sign on to your system with the Administrator user account you will use to run the installer. Click the Start Orb and type %temp% in the search box. The search results will show the Temp folder you want. Click on the Temp folder to open it in Windows Explorer, then delete the entire contents.

    3. Run the standalone installer from step 1 As Administrator.

    Note: Just using an administrator account is NOT enough. To activate full privileges, you must right-click the installer, then select Run as administrator.

    If the install fails, provide complete install logs as follows:

    Please collect your install logs with this:

    http://aka.ms/vscollect

    After you run Collect.exe, you'll find vslogs.cab in your %temp% directory. Please upload vslogs.cab to a public site, like SkyDrive, and post the link here.

    Saturday, March 8, 2014 5:00 PM

All replies

  • Error 0xc8000222 indicates a Windows Update issue.

    In your case, Service Pack 1 for Windows 7 is not installed.

    Please install SP1 for Windows 7 and all subsequent patches, then retry the .NET 4.0 install as follows:

    Follow these steps exactly:

    Before trying to install .NET Framework 4.0, execute this command from an ELEVATED Command Prompt provided by the .NET Framework Team:

    "This issue is likely caused by a bad ACL on assembly\tmp folder. After installing updates, the ACL propagates to installed assembly folders in both 4.0 & legacy GAC.  If those updates were installed by WU or another user, the propagated ACL will prevent install of the same assembly by the current user.

    A work around would be to reset the ACL on GAC dirs.

    for /F %D in ('dir %WINDIR%\assembly %WINDIR%\Microsoft.NET\assembly /s /b /a:d') do takeown /F %D && icacls %D /reset /T"

    After running that command, follow these steps:

    Please follow these instructions exactly:

    1. Download a fresh copy of the standalone installer for .NET Framework 4.0:

    http://www.microsoft.com/en-us/download/details.aspx?id=17718

    2. Also, clear your %temp% directory and disable your AV software.

    The %temp% directory is a reference to the Temp folder associated with the current user. To clear it, do the following:

    Sign on to your system with the Administrator user account you will use to run the installer. Click the Start Orb and type %temp% in the search box. The search results will show the Temp folder you want. Click on the Temp folder to open it in Windows Explorer, then delete the entire contents.

    3. Run the standalone installer from step 1 As Administrator.

    Note: Just using an administrator account is NOT enough. To activate full privileges, you must right-click the installer, then select Run as administrator.

    If the install fails, provide complete install logs as follows:

    Please collect your install logs with this:

    http://aka.ms/vscollect

    After you run Collect.exe, you'll find vslogs.cab in your %temp% directory. Please upload vslogs.cab to a public site, like SkyDrive, and post the link here.

    Saturday, March 8, 2014 5:00 PM
  • 1.) open "cmd"

     2.) type in command "net stop "WuAuServ" (disable windows update)

     3.) Head over to Run ( Win+R ) and type in "%windir%" (this command line enable you to head over to your microsoft windows system folder)

    4.) Find the folder "SoftwareDistribution" and rename it as "SDold"

    5.) Then, go back the previous command prompt and also run the command line "net start WuAuServ"

    6.) At this point, try to install. NET Framework again.


    I hope this will help solve the problem if you have questions in mind please do comment it below the post I will be glad to answer them all.
    • Proposed as answer by PARAG.WAGHELA Thursday, October 30, 2014 6:43 PM
    Thursday, October 30, 2014 6:43 PM