none
Error with framework versions conflict RRS feed

  • Question

  • HI,

    i get an error while compiling. This error:

     The primary reference "DYMO.Label.Framework" could not be resolved because it has an indirect dependency on the assembly "DYMO.DLS.Runtime, Version=8.6.611.42161, Culture=neutral, PublicKeyToken=5426002a38745af9" which was built against the ".NETFramework,Version=v4.5.1" framework. This is a higher version than the currently targeted framework ".NETFramework,Version=v4.5".    VoorraadBeheer    C:\Program Files (x86)\MSBuild\14.0\bin\Microsoft.Common.CurrentVersion.targets

    It seems to be that there is an conflict between version 4.5 and 4.5.1

    How to suppress this error?

    Rinaldo 


    Greetings from Amsterdam the Netherlands

    Monday, July 10, 2017 7:35 PM

Answers

  • No you don't have a problem with EF. Your problem is with what is in the link.

    http://developers.dymo.com/2010/06/02/dymo-label-framework-overview/

    What you are being told is that the Dymo DLL was created against the 4.5.1 .NET Framework. Your solution that you are using that is trying to use the Dymo DLL compiled against the 4.5.1 Framework is being used in your solution that is using the .NET 4.5 Framework.

    How to suppress this error?

    Your solution has to be upgraded to the 4.5.1 Framework if you want to use the Dymo DLL.  that was compiled against the 4.5.1 Framework.

    Monday, July 10, 2017 8:16 PM
  • Hi Rinaldo1961,

    You need to upgrade your current .NET Framework to 4.5.1 to run the app. Because your app was built with .NET version 4.5.1 so when it get compiled it is searching 4.5.1 on your machine. Please go to the below link and download the 4.5.1 version. Hope this helps you.

    Microsoft .NET Framework 4.5.1 (Offline Installer)


    Thanks,
    Sabah Shariq

    [If a post helps to resolve your issue, please click the "Mark as Answer" of that post or click Answered"Vote as helpful" button of that post. By marking a post as Answered or Helpful, you help others find the answer faster. ]


    Monday, July 10, 2017 8:19 PM
    Moderator

All replies

  • No you don't have a problem with EF. Your problem is with what is in the link.

    http://developers.dymo.com/2010/06/02/dymo-label-framework-overview/

    What you are being told is that the Dymo DLL was created against the 4.5.1 .NET Framework. Your solution that you are using that is trying to use the Dymo DLL compiled against the 4.5.1 Framework is being used in your solution that is using the .NET 4.5 Framework.

    How to suppress this error?

    Your solution has to be upgraded to the 4.5.1 Framework if you want to use the Dymo DLL.  that was compiled against the 4.5.1 Framework.

    Monday, July 10, 2017 8:16 PM
  • Hi Rinaldo1961,

    You need to upgrade your current .NET Framework to 4.5.1 to run the app. Because your app was built with .NET version 4.5.1 so when it get compiled it is searching 4.5.1 on your machine. Please go to the below link and download the 4.5.1 version. Hope this helps you.

    Microsoft .NET Framework 4.5.1 (Offline Installer)


    Thanks,
    Sabah Shariq

    [If a post helps to resolve your issue, please click the "Mark as Answer" of that post or click Answered"Vote as helpful" button of that post. By marking a post as Answered or Helpful, you help others find the answer faster. ]


    Monday, July 10, 2017 8:19 PM
    Moderator