none
Azure Linux VM Backup Failing RRS feed

  • Question

  • I am trying to setup backups for my linux VMs in Azure. I am doing it through the Recovery Services facility.

    All my Linux VMs are discovered and successfully registered.

    But when the backup jobs run they fail for all my VMs with the following error:

    Backup failed with an internal error. Please retry the operation in a few minutes. If the problem persists, contact Microsoft Support.

    No more details on the errors, I have tried to re-run the jobs mutliple times and same result.

    I have looked into the docos and I found this:

    You can get this error for 2 reasons:

    1 - There is too much data to be copied. Please check if you have less than 6 disks.

    2 - The original VM has been deleted and therefore backup cannot be taken. In order to keep the backup data for a deleted VM but stop the backup errors, Unprotect the VM and choose the option to keep the data. This will stop the backup schedule and also the recurring error messages.

    None of the above apply, the VM has not been deleted and only one data disk per VM.

    Linux VMs were created form the Gallery so I assume the VM Agent is configured correctly (they are discovered by the Recovery Service)

    Any ideas or what to look for?

    Wednesday, July 15, 2015 1:23 AM

Answers