locked
Adding intranet url to the Report Manager RRS feed

  • Question

  • I have an installation of Reporting Services 2008 r2 on Windows Server 2008 r2.  I would like to add a url to the report manager so that I can access the report manager as such http://mynewurl/reports.  I've added the new url via the Report Manager Url tab of the Reporting Services Configuration tool.  When I click the http://mynewurl/reports from the Reporting Services Configuration window a new window opens up but I receive a generic error message that the page cannot be displayed.

    Is there any additional set up that needs to be done outside of reporting serives for the url to resolve correctly?

    Can anyone help please?!

    Wednesday, December 29, 2010 10:37 PM

Answers

All replies

  • What is that mynewurl you used? To enable intranet and extranet access to a report server, you might use the default URL for access across the intranet, and an additional fully qualified host name for extranet access:
    • http://myserver01/reportserver
    • http://www.adventure-works.com/reportserver

    You can create multiple URLs to support access through a fully qualified domain name (FQDN) that will be used by external users, and a different URL that uses the network name. Using two different URLs will allow you to connect to the report server if your Internet connection is disabled or offline. You should select SSL certificates for the FQDN URLs that you define.

    Refer:
    http://msdn.microsoft.com/en-us/library/ms159272.aspx [Planning for Extranet or Internet Deployment]
    http://msdn.microsoft.com/en-us/library/bb630447.aspx [How to: Configure a URL (Reporting Services Configuration)]
    Thanks

     


    Chaitanya
    Thursday, December 30, 2010 3:19 AM
  • Thanks for the reply! I've read over those msdn articles.  This scenario is just for intranet access.  I'm aware that I could just use the default url but it doesn't have a very friendly name. I would like to create a report manager url with a different name that can be used internally (intranet).

    To simplify things I am now have every set up on my Windows XP machine instead of windows server.

    I addition to adding the new url http://mynewurl/reports to the reporting services configuration, I added an entry in the host file to resolve mynewurl to the localhost ip 127.0.0.1

    Now when I visit http://mynewurl/reports I'm getting prompted to enter a user name and password.  When I enter my username and passowd (I'm an admin)  I am not authenticated and I end up at a blank webpage.

    I have success accessing the report manager via localhost and the machine name.

    Please help

    Thursday, December 30, 2010 9:47 PM
  • Hi Dramiko

    I would say that since you have success accessing the report manager using the localhost and the machine name, one thing that comes to mind is to make sure the mynewurl is one of the trusted site in your IE setting.

    As for the windows server setup, don't forget to set up an alias in DNS that mapped the mynewurl to your windows servername.

    Thank you

    Lucas

    Thursday, December 30, 2010 10:16 PM
  • Yes, I agree with Lucas. You need to have a DNS entry mapped with mynewurl. Host entry will only resolve your local requests on the server. But if you intend  to call this url externally, then you need a DNS entry.

     


    Chaitanya
    Friday, December 31, 2010 3:08 AM
  • Right now I'm just trying to get it to work on my windows xp machine.

    I have an entry in the host file mapping mynewurl to 127.0.0.1

    Friday, December 31, 2010 4:10 PM
    • Marked as answer by Tony Chain Thursday, January 6, 2011 1:39 AM
    Saturday, January 1, 2011 12:19 AM