none
What is the recommended and supported Targeted .Net Framework version for U-SQL Class Library?

    Question

  • Is it still .Net Framework 4.5.2?  If a later version (such as 4.7.1) is targeted, built and registered should that cause issues or errors?

    Bill Blakey

    Friday, May 18, 2018 6:54 PM

Answers

  • It is still 4.5.2. We are working through the timeline to upgrade to 4.7.1, but there is no ETA at this point. Major items are backwards-compatibility of user jobs.

    If you use a 4.7.1 targeted assembly dll, you will get an error on loading the dll in the 4.5.2 environment.


    Michael Rys

    Friday, May 18, 2018 10:58 PM
    Moderator

All replies

  • It is still 4.5.2. We are working through the timeline to upgrade to 4.7.1, but there is no ETA at this point. Major items are backwards-compatibility of user jobs.

    If you use a 4.7.1 targeted assembly dll, you will get an error on loading the dll in the 4.5.2 environment.


    Michael Rys

    Friday, May 18, 2018 10:58 PM
    Moderator
  • Ok, thank you for the response!

    Bill Blakey

    Saturday, May 19, 2018 1:38 AM