locked
Can I run a Core 3.1 App on ASP.NET Core Runtime 5.0.4? RRS feed

  • Question

  • User1555919309 posted

    I downloaded and installed hosting bundle 5.0.4 to my web server. However, it gives me error. (https://docs.microsoft.com/en-us/aspnet/core/host-and-deploy/iis/hosting-bundle?view=aspnetcore-5.0&viewFallbackFrom=aspnetcore-3.1) Can I run a Core  3.1 App on ASP.NET Core Runtime 5.0.4? If no, what version should I install? Thanks.

    IIS Error

    Here is the event viewer log:

    Could not find 'aspnetcorev2_inprocess.dll'. Exception message: It was not possible to find any compatible framework version. The framework 'Microsoft.AspNetCore.App', version '3.1.0' was not found.  - The following frameworks were found:      5.0.4 at [C:\Program Files\dotnet\shared\Microsoft.AspNetCore.App] You can resolve the problem by installing the specified framework and/or SDK.

    Thursday, March 25, 2021 2:20 PM

All replies