locked
Unable to hit on BizTalk Server RRS feed

  • Question

  • Hi All,

    My scenario is as follows :

    Before implementing with BizTalk, the workflow for actual service is as follows:

    1. First client A consume the service B

    2. Then Client A sends the request to Service B and service B give response to A.

    Now we consume the service B in BizTalk and expose orchestration as a wcf service.We got a new biztalk url and we tested it with wcf test client and it is working fine.

    Now in client A web config file, I replace the original url with biztalk url

    and when client A sends request to BizTalk , we are not getting any request.No errors in log.

    Why it can be happen ?How can we track that which server hits the biztalk ?

    Should I again consume the Biztalk url in service A and then try to hit it ?

    Wednesday, February 17, 2016 2:29 PM

Answers

  • After cheking the event logs , we are getting 500 error as follows:

    2016-02-19 17:41:27 172.16.12.35 POST /MyService.asmx WSDL 80 - clientIP(let X) Mozilla/4.0+(compatible;+MSIE+6.0;+MS+Web+Services+Client+Protocol+4.0.30319.1) 500 0 0 218

    how can I find the inner details of the above error ?

    After checking the web service form SOAP UI and WCF test client; it is working fine.

    Monday, February 22, 2016 11:39 AM

All replies

  • Hi Narayan,

    As per your explanation

    U have created a BizTalk wrapper services on top of B services--U have exposed BizTalk orchestration as service.

    the IIS server which u have hosted BizTalk(wrapper Service) should run under the same account what BizTalk is running or Account should have permission on to it.

    when client A is calling your wrapper service-Please check your IIS logs and Event viewer(In which server u have deployed the service).


    Wednesday, February 17, 2016 6:13 PM
  • Did you check the binding? what binding u used to expose the service. Is client A is using same binding.

    If you are using WSHttp binding check the security. Did you make security none in your receive location.

    Wednesday, February 17, 2016 6:27 PM
  • Hi Narayan,

    Can you please try consuming the BizTalk service from fillder/soapUI to make sure the service is working?

    Cheers


    JB

    Wednesday, February 17, 2016 8:35 PM
  • After cheking the event logs , we are getting 500 error as follows:

    2016-02-19 17:41:27 172.16.12.35 POST /MyService.asmx WSDL 80 - clientIP(let X) Mozilla/4.0+(compatible;+MSIE+6.0;+MS+Web+Services+Client+Protocol+4.0.30319.1) 500 0 0 218

    how can I find the inner details of the above error ?

    After checking the web service form SOAP UI and WCF test client; it is working fine.

    Monday, February 22, 2016 11:39 AM