locked
How to set Image property for UIImageView in Storyboard editor? RRS feed

  • Question

  • User70711 posted

    I've asked the same question in Xamarin in Visual Studio subforum with no answer...So please if anyone could help me with this.

    I'm having trouble setting Image property of UIImageView in Storyboard editor in VS2017. I select UIImageView in Storyboard and in properties pane try to select Image but that triggers Open File Dialog and selecting an image there just adds it to the root of my project and does nothing with the my UIImageView.

    Saturday, June 3, 2017 10:57 AM

Answers

  • User70711 posted

    It just started to work with next update.

    • Marked as answer by Anonymous Thursday, June 3, 2021 12:00 AM
    Monday, October 2, 2017 11:59 AM

All replies

  • User21936 posted

    @MarkoBrkovic

    Sounds like a bug I once filed: https://bugzilla.xamarin.com/show_bug.cgi?id=45088

    or a similar one: https://bugzilla.xamarin.com/show_bug.cgi?id=43226

    Perhaps try adding the image to your Resources folder first (or to an image set in your asset catalog if using asset catalogs for your images) and then opening the storyboard. IN the case of the first bug noted above, the issue was that the iOS Designer did not pick up images added while the storyboard was open, so you had to close and re-open the storyboard to pick up any new images.

    Tuesday, June 6, 2017 1:39 AM
  • User70711 posted

    Well, I thought it might be the problem, but I have existing images in Resources folder and I opened and closed Storyboard a million times. I guess it is a bug then. It actually started acting out since the last Visual Studio/Xamarin update.

    Tuesday, June 6, 2017 6:42 AM
  • User70711 posted

    It just started to work with next update.

    • Marked as answer by Anonymous Thursday, June 3, 2021 12:00 AM
    Monday, October 2, 2017 11:59 AM