locked
Getting DCOM error -2147024829 when trying to run our software on one of our customer's machines RRS feed

  • Question

  • We have a client - server application that runs on Windows XP, Vista, 7, 2000 server, 2003 server and 2008 server OS platforms, and have many customers running in each environment.  We have customer running both 32 bit and 64 bit versions of the OS as well.  This application uses DCOM as the protocol for the client to communicate with the server.  We often have to tweak the DCOM to get it to work in different customer environments, but we can always get it working

    One of our large customer recently installed our software on VMWare 2008 64 bit server machines.  Everytime they try to run the client, it errors with -2147024829 error - which is network resource not found or not available.  Normally the errors we see are permission errors, this is unique

    The machine in question can access shared drives on the server without any problem.  I realize that's done differently, but there is communication going on between the two machine.

    I had downloaded a DCOM tester (tstclnt and tstsrvr) from the Microsoft site.  Normally if this fails, I tell the customer they have a systems problem and they need to get their computer people to resolve that.  If the test utility from Microsoft fails, our application will most likely fail as well, as DCOM is not functional from that machine.

    In this case, the dcom test utility from Microsoft works fine.  It is only our application that is not working in their environment.  I tried setting up our app the same way the dcom test utility was set up, but no matter what I do, our app fails with a -2147024829 error.

    There are also not entries in the event log on either the client or the server to give us additional information.

    I have tried opening up permissions to Everyone (and even to Anonymous) for both our app and in the my computer properties.  I have tried all three users (interactive, launching, and a specific user)  I have tried running dcomcnfg on the client and setting it up in there - even telling it to run the app on the specified computer.  No matter what I try, I continue to get the -2147024829 error when I run the application.

    I have asked that we set up some VMWare machines, just to see if that's part of the problem.  Hopefully I'll get that in the next couple of days, but am trying to find another solution in the meantime

    They do have their machines locked down fairly tight, so it could be something in the way they have the network configured.

    At this point I am baffled.  Does anyone have any ideas or have anything that I might be able to try to resolve this?

    Thanks

    Friday, October 29, 2010 12:47 AM

All replies

  • Just FYI, we finally got this working.  One of the people in our company is more familiar with virtual environments than I am.  He remoted into the machines and changed the Networks on both virtual machines from Public to Work.  I then started getting error -2147221164, which is class not registered, so I reinstalled the software and now it's working great

    I wanted to pass that along for anyone else who might run into something like this


    Tuesday, November 9, 2010 10:05 PM