locked
Set version number for Silverlight package? RRS feed

  • Question

  • I can't set a new version for a Silverlight package.

    The app is here: http://www.windowsphone.com/en-gb/store/app/webstore/99277ab3-92b3-43ac-a5b6-6400d53f154b

    Previously in VS Express 2013 there was an item on the Store menu to create a package. This has now gone. A package still gets created when I build. But I can't set the new version number.

    I have files called WMAppManifest.xml and Package.appxmanifest.

    I've given up trying to figure out which each does. Both of them have a version field. In both, I have set the version to 1.0.0.28 but when I upload the package (after rebuilding) it keeps the old version number of 1.0.0.26 and then complains because I haven't provided a package with a higher version number.

    As I say, this has all happened since the options to create a package disappeared from the Store menu.

    Anyhow, how can I upload the new version?

    Sunday, November 2, 2014 12:06 PM

Answers

All replies

  • The Store menu is (and always has been) for Windows Runtime apps, not for Silverlight apps. Silverlight apps use the xap file created as part of the general build process. I discuss this in my blog entry at  Why can’t I create an app package? Windows Phone Xap vs. Appx   

    As documented at Prepare your Windows Phone Silverlight 8.1 app for publishing:

    Before you publish an update for your Silverlight 8.1 app, you have to manually increment the app version in the appxmanifest.xml file.

    That page also explains which fields need to be updated in the WMAppManifest.xml and which in the Package.appxmanifest

    --Rob

    • Marked as answer by Dave Curtis Tuesday, November 4, 2014 9:33 AM
    Tuesday, November 4, 2014 12:13 AM
  • OK, thanks. I'll have a go at doing that. It would be nice if this were a bit more obvious from within Visual Studio.

    It's bizarre, I could have sworn that I saw those Store menu items before.It's only very recently I've worked on any apps which weren't Silverlight so I don't see how I would have been aware of them if they hadn't previously been visible for Silverlight apps. Oh well.

    Tuesday, November 4, 2014 6:05 AM
  • I've had a quick look and I'm starting to see why this is so difficult.

    If I look in Solution Explorer I don't have anything called appxmanifest.xml.

    Among the source files I have one called Package.appxmanifest. This has got a version number in it but last time I tried when I updated this it wasn't recognised as being in the package and the package seemed to still have the old number.

    In properties I have something called AppManifest.xml. I have no idea what this is or whether I need it. All it has in it is this:

    <Deployment xmlns="http://schemas.microsoft.com/client/2007/deployment"
            xmlns:x="http://schemas.microsoft.com/winfx/2006/xaml"
    >
        <Deployment.Parts>
        </Deployment.Parts>
    </Deployment>

    I think we're probably talking about Package.appxmanifest. I tried adding the extension .xml but then I couldn't build the project. 

    Now I'm getting an error message saying:

    Error 1 Project must have either AppxManifest item or Content item with name 'AppxManifest.xml'.

    Please can you tell me exactly what filenames I should have, what folders they should be in and how to add them to the project? I don't really know what an "item" is in this context and I can't get either of the above to work.

    Tuesday, November 4, 2014 8:59 AM
  • OK, with this I can at least build the project:

    I have to name the file AppxManifest.xml.

    I put it in the Content folder - I don't know if I had to do that.

    I did Project, Add Existing Item. This added it to the list of source files. I still have something with the same name in the project properties which I am afraid to delete.

    Then (this is what fixed it) I right-clicked on it, selected Properties, and under Advanced changed the Copy to Output Directory to Copy Always.

    Doing this did then allow me to change the package version number, thanks.

    Tuesday, November 4, 2014 9:15 AM
  • Sorry, that's not quite right. The file in Content is AppxManifest.xml and the file in Properties is AppManifest.xml.
    Tuesday, November 4, 2014 10:49 AM
  • Actually, adding an AppxManifest.xml file did not work either. I got this error after submission:

    • Error Found: The app manifest test detected the following errors:
      • The app manifest declares an unsupported architecture.


    In the end I had to edit the csproj file with a text editor and then change the version number in Package.appxmanifest, which is in the project folder. 

    Tuesday, November 4, 2014 11:17 AM