none
Cannot delete storage account

    Question

  • I create a new VM in the Preview, which presumably created a Storage account.

    I then closed and deleted the VM, but the storage account remained.

    When I try and delete it I get:

    "Storage account *********** has 1 container(s) which have an active image and/or disk artifacts. Ensure those artifacts are removed from the image repository before deleting this storage account."

    There is nothing else showing in the account. Everything is zero.

    Is there something else that has to be cleared to remove this?

    -c.

    Friday, June 08, 2012 6:33 PM

Answers

  • If you want to delete the storage account, you need to delete any images/disks you have remaining in that storage account.

    Go to Virtual Machines -> "Disks" or "Images" tab -> select the images/disks that you have located in the Storage Account you want to delete -> then hit the "Delete disk" or "delete image" command. Back these up if you need before hitting the delete.

    Once the images/disks in the storage account have been deleted, you should be able to delete the storage account. Hope this helps.


    Friday, June 08, 2012 8:14 PM

All replies

  • If you want to delete the storage account, you need to delete any images/disks you have remaining in that storage account.

    Go to Virtual Machines -> "Disks" or "Images" tab -> select the images/disks that you have located in the Storage Account you want to delete -> then hit the "Delete disk" or "delete image" command. Back these up if you need before hitting the delete.

    Once the images/disks in the storage account have been deleted, you should be able to delete the storage account. Hope this helps.


    Friday, June 08, 2012 8:14 PM
  • Thanks, Vignan, that was it.

    I didn't know there were extra tabs when selecting Virtual Machines. I saw the zero count next to it and just assumed it was empty. Apparently not.
    Friday, June 08, 2012 9:34 PM
  • Hi,

    Same issue. The VM are deleted but impossible to delete the storage acconut.

    When I use azure explorer to delete the vhd file, It indicate : Thre is currently a lease on the blob and no lease ID was specified in the request.


    Francois Michael Dain

    Tuesday, June 12, 2012 9:30 AM
  • I never saw the tabs until I searched for the same problem. I hope they make it more visible. Thank for your help.
    Wednesday, July 25, 2012 7:45 PM
  • I have the same problem, thanks for point out the solution

    Monday, July 30, 2012 4:09 PM
  • i have the same issue please give me fix for that.

    the deleted button is disabled and i have tried this in all the browsers.

    it might be some different issue microsoft should look into this.

    Friday, March 22, 2013 5:15 AM
  • Thanks, Vignan, that was it.

    I didn't know there were extra tabs when selecting Virtual Machines. I saw the zero count next to it and just assumed it was empty. Apparently not.
    I assumed the very same thing. This is bad user design.

    Planet Earth, Europe, Denmark, Sealand, Copenhagen, Morten

    Thursday, October 03, 2013 1:36 PM
  • Step1:
    ==========
    Set-AzureSubscription -SubscriptionName (Get-AzureSubscription).SubscriptionName -CurrentStorageAccountName (Get-AzureStorageAccount).Label

    Step2:
    ==========
    Run Get-AzureDisk and get the diskname

    Step4:
    ==========
    Now, try removing the Disk using below command
    Remove-AzureDisk DISKNAME
    for e.g., Remove-AzureDisk 'DISK-201501291246370620'

    Now, try removing the VHD via the portal and it should succeed.

    Later, you can delete the Storage account either via the portal or via Powershell remove-azurestorageaccount


    Sushant Rao http://blogs.technet.com/sushrao


    Tuesday, February 03, 2015 11:25 AM
  • You can see the storage by storage explorer from codeplex which is free or cerebrata has also good azure storage explorer. I that you can see virtual machine VHD files also under container vhd and you can delete one by one. If the VHD is corresponding to active VM then you need to delete the VM first.
    • Proposed as answer by Mahesh Malpani Thursday, February 05, 2015 7:36 AM
    Thursday, February 05, 2015 7:36 AM