locked
HelloWorld Sample problem RRS feed

  • Question

  • Hi,

    I dont seem to be able to get the Helloworld sample working, whenever I press the createsession button i get a SoapFaultException. Checking the Application log gives the following Failure Audit error:
     Login failed for user 'Session-service'[Client: <local machine>] from the source MSSQL$SQLEXPRESS.
    A second error whose source is session gives: Error detail - System.Data.SqlClient.SqlException: Login failed for user 'Session-Service'.

    Do I need to give Session-Service an account on the SQL Server?

    Looking at another thread from this forum I noticed that this worked for another user after they changed the authentication mode to mixed authentication mode, this didnt work for me.
    I then noticed that I could not log onto the Microsoft SQL Server Managment Studio Express using the Session-service username and password as given in the Session.config file.
    I created a user (sql_login" on the SQL Server and changed the Session.config file to use this user when connecting to the Server. This did not work again, but I got a slightly different error message:
    Error detail - System.Data.SqlClient.SqlException: Cannot open database "CSFSessionDB" requested by the login. Login failed for user 'sql_login'.
    I have verified that the following 3 attributes are correct:

    SessionManagerUri, UIFormUri, ParticipantUri.

    Any help would be greatly appreciated.


    John


    Wednesday, February 28, 2007 4:37 PM

Answers

  • Hi - By default SQL Server works on Windows Authentication mode. You need to change that to "mixed mode" which is SQL Server and Windows Authentication mode.

    You could do that by launching the Management console. Edit the server properties. Go to security tab. Choose the option "SQL Server and Windows Authentication mode".

    Restart SQL Server service. It should work.

    Thanks

    Tuesday, March 6, 2007 5:34 AM

All replies

  • Hi,

    The database CSFSessionDB is not present in my Sql Server 2005 instance, it seems to be this is the problem. Does anyone know when this gets created does it get created when CSF Dev Lite is installed or is there a bat file that does it or how does it work?

    John
    Thursday, March 1, 2007 11:54 AM
  • Hi John,

    Change your SQL Server Loginmode property to '2' in registry editor.

    Thursday, March 1, 2007 12:11 PM
  • Hi,

    cheers for the reply but unfortunately it already is, I think my problem is to do with the CSFSessionDB  database and other procedures being missing from the Server. I reinstalled SQL Server and I think that is the problem I just amnt sure how to get these back again.

    John
    Thursday, March 1, 2007 1:25 PM
  • Hi - By default SQL Server works on Windows Authentication mode. You need to change that to "mixed mode" which is SQL Server and Windows Authentication mode.

    You could do that by launching the Management console. Edit the server properties. Go to security tab. Choose the option "SQL Server and Windows Authentication mode".

    Restart SQL Server service. It should work.

    Thanks

    Tuesday, March 6, 2007 5:34 AM