locked
Unable to resolve a PeerName RRS feed

  • Question

  • Hi all!

    I have copied-and-pasted into two different solutions the example of Peer-to-Peer registration and discovery that are available at http://blogs.msdn.com/p2p/archive/2007/03/12/writing-peer-to-peer-applications-using-net-part-1-pnrp.aspx. When I try them on the same computer, everything works as expected. However, if I try to run the registration program on a PC with Windows Vista and the discovery program on another computer with Windowx XP (in the same LAN), or viceversa, the discovery procedure always returns 0 result.

    I have no idea about the problem. Could someone help me?

    Thanks in advance.
    Wednesday, January 2, 2008 8:04 PM

All replies

  • Hi Marco,

    Thanks for your interest in p2p technologies.

    If you are running XPSP2, you need upgrate XPSP2 by downloading PNRP v2 from following link.

    http://support.microsoft.com/default.aspx/kb/920342

     

    You will also find the PNRP debugging guide at

    http://blogs.msdn.com/p2p/archive/2007/07/24/pnrp-debugging-guide-part-1.aspx

     

    Please let me know if you need more information.

    Thanks,

    Pritam

     

     

     

    Wednesday, January 2, 2008 8:47 PM
  • Thank you for the response.

    I have already installed the Windows XP Update. Following the instruction written in the blog post you pointed me out, I have discovered that the Global_ cloud was in the virtual state in either the Vista and the XP computer. The command

     

    netsh p2p pnrp cloud start Global_

     

    put it the correct Active state. However, the demo application still doesn't work. I have than tried to test the connectivity between the two machines. If I use the command

     

    netsh p2p pnrp diag ping host [host=]{<ip address> | <host name>}  [cloud=]<cloud name>

     

    Specifing the host name of the machine where I run the command, I obtain the message "Destination did not respond (error 0x80980800)". When I try with the name of the other computer, I get another error message, saying that it is impossibile to find the host name in the cache. Either the PC are connected to the Internet.

     

    Any other ideas?

    Thursday, January 3, 2008 3:15 PM
  • Hi Marco,

    Can you check if the Firewall (FW) port is opened in all machines for PNRP (UDP 3540)? To narrow down the issue, can you please follow the debugging instructions mentioned in p2p blog? You can directly send me an email at pritamd@microsoft.com.

    Thanks,

    Pritam

     

     

    Thursday, January 3, 2008 11:28 PM
  • Hi!

     

    Perhaps I have found the issue.

    If I try to register a secure PeerName, I obtain an authority that is
    different for each user. This way, when I try to resolve the PeerName,
    the object that is used to perform the search (because it is executed
    by another user) has another autorithy, so the procedure returns
    always 0 peers. Can you confirm this behaviuor? If I am right, the
    only way to register and discovery peers on the Net is using
    unsecuring PeerName, or is there another solution?

    Thanks again!

    Monday, January 7, 2008 11:19 AM
  • Hi Marco,

     

    Wondering if anybody got back to you with an answer on this (obviously they haven't in this forum) because I'd be interested in knowing the solution to this as well.

     

    Regards,

     

    Roland Rodriguez

    Wednesday, February 6, 2008 8:55 PM
  •  

    No, I'm sorry, this is all that I have known about the issue.
    Thursday, February 7, 2008 8:38 AM
  • Hi folks,

    PNRP should be able to resolve both secure and unsecure names equally well. 

     

    From one machine, you should be able to resolve peer names constructed using any other authority.  You can resolve names published by yourself (not from the same process that they were registered with though if you're using PNRP NSP directly) and you can resolve names published by other people. 

     

    Are you able to get your machines to work in a link local cloud?

     

    Are you able to icmp ping your XP machine from the Vista computer?  ping -6 <global ipv6 address>

     

    Teredo doesn't support hairpinning on some NATs.  Hairpinning is when you use a NAT traversal technique to connect back to another host on the same link.  This sounds like your situation.  If your NAT doesn't support harpinning, you won't be able to ICMP ping the XP machine from the Vista computer.  You'll have to use a link local cloud.

     

    Does netsh p2p pnrp cloud show list show your link local clouds as active on both computers?

     

    -Tyler

     

     

    Wednesday, February 20, 2008 2:27 AM