locked
User Profile Service App - Property mapping to 'description' AD attribute RRS feed

  • Question

  • Hi all,
      
    In AD we're using the attribute 'description' to hold job titles (instead of the 'title' AD attribute).
      
    I'm trying to add a new mapping to the existing 'Title' property in the User Profile Service Application, but 'description' doesn't appear in the drop down list of AD attributes. 
      
    I'm just wondering if someone could confirm whether this attribute is missing in their UPA? Or if anyone can shed any light on this? Is it appearing in the list under a different name?
      
    I'm using SharePoint Server 2010 - SP1 and the December 2011 CU.
      
    Recreation steps:
    • Go to User Profile Service Application
    • Click on Manage User Properties under People
    • Click the drop down next to the Title property and select Edit
    • Scroll down to Add New Mapping section
    • Select AD connection from Source Data Connection drop down
    • Click on the Attribute drop down and look for 'description' attribute
    • 'description' attribute is not in the list
    Thanks
    Alasdair


    • Edited by Al 76 Wednesday, January 4, 2012 5:35 AM
    Wednesday, January 4, 2012 5:34 AM

Answers

  • Yes, it is missing in my test farm as well. I can make an assumption that this is because description attribute in AD is multi-valued (isSingleValued = FALSE in AD Schema), though I cannot find any confirmation in the official documentation that multi-valued attributes cannot be synced.

     

    UPDATE: My bad, of course, you cannot sync single valued string in UPA to multi-valued attribute in AD. All you need to do is just create a new property with type string (Multi Value) and then you will see AD description attribute in the list.

    • Edited by pavel.gz Wednesday, January 4, 2012 6:15 AM
    • Marked as answer by Al 76 Wednesday, January 4, 2012 9:44 PM
    Wednesday, January 4, 2012 6:10 AM

All replies

  • Yes, it is missing in my test farm as well. I can make an assumption that this is because description attribute in AD is multi-valued (isSingleValued = FALSE in AD Schema), though I cannot find any confirmation in the official documentation that multi-valued attributes cannot be synced.

     

    UPDATE: My bad, of course, you cannot sync single valued string in UPA to multi-valued attribute in AD. All you need to do is just create a new property with type string (Multi Value) and then you will see AD description attribute in the list.

    • Edited by pavel.gz Wednesday, January 4, 2012 6:15 AM
    • Marked as answer by Al 76 Wednesday, January 4, 2012 9:44 PM
    Wednesday, January 4, 2012 6:10 AM
  • Thanks - that explains why I couldn't see description in the list.

    I think the long term solution will be to get the data in AD corrected :)


    Alasdair Marshall
    Wednesday, January 4, 2012 9:55 PM