locked
Git local only problem RRS feed

  • Question

  • Hello, strange (at least to me) thing happens when using fresh VS 2015 Update 1 installation:
    a moment after I modify a code file the file status spontaneously changes to 'unchanged', no commit is possible.

    I use local repository only.

    Please advise. I am stuck :/

    Thursday, February 4, 2016 1:34 AM

Answers

  • Tingting,

    how do I share my solution?

    In any case, I recreated the solution from scratch and the issue seems gone away.

    Thanks,

    Tomasz

    Wednesday, February 10, 2016 12:30 PM

All replies

  • Hi,

    Thanks for posting to our forum.

    >>I modify a code file the file status spontaneously changes to 'unchanged', no commit is possible.

    Could you tell me where can I see the file status?

    Did you mean the file does not exist in the Included changes folder?  And the file showed in the Excluded changed folder?

    If your problem is like this. I suppose the file was ignored by the system. You could set it with the following steps:

    1.Team Explorer->Home->Settings->Repository Settings

    2.In Ignored File, click Edit

    3.Remove your file in this configuration file.

    Please delete the corresponding file in the this setting file then try it again.

    In addition, if you could share us a UI of your issue or detailed steps to reproduce it, it would also be helpful to the troubleshooting.

    If I misunderstood your issue. Please feel free to let me know.

    Best Regards,

    Lake Xiao

    Thursday, February 4, 2016 6:28 AM
    Moderator
  • Hello Lake,

    I put on YouTube a movie illustrating the problem
    http://www.youtube.com/watch?v=F7CEtFM_w_Q
    The sound level is very low, you may need to adjust the volume.

    Only one of my VS solutions is affected.

    Thanks for any pointers.

    Tomasz


    Thursday, February 4, 2016 5:26 PM
  • Hi Tomase,

    I have seen the video you uploaded.

    And I thin your issue is more related to the TFS Source control. I moved it to the Source Control for better support.

    Thanks for your understanding.

    Best Regards,

    Lake Xiao

    Friday, February 5, 2016 2:09 AM
    Moderator
  • Hi Tomase,

    I have already seen that video, and I found that your issue is that when you want to commit the changes, the paragraphElement.cs file was at the Included changes folder. After you click Commit,  it takes an error.

    Are other files in this solution has this issue or just this file? If other files are OK, you could delete this file and add a new one. This is the fast solution to your problem.


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Friday, February 5, 2016 7:51 AM
    Moderator
  • Hi Lake,

    I do not understand, I do NOT use TFS at all. It is a local Git repository!
    But this gives me a clue. This solution used to be stored in TFS. Maybe there some remaining settings which cause the problem? I removed all the *.vssscc files and Scc* settinggs from solution files. Still no progress :(

    BR,

    Tomasz




    Friday, February 5, 2016 9:02 AM
  • All the files are affected, not just this particular one.

    Thanks,

    TJ

    Friday, February 5, 2016 9:03 AM
  • The proosed solution does not work, newly added files exhibit the same problem. See:

    http://www.youtube.com/watch?v=BJ6U6y8A44w

    BR,

    Tomasz


    Friday, February 5, 2016 11:10 AM
  • Hi Tomasz,    

    Thanks for your reply.

    The issue only happened in this one specific solution?

    Other solutions or new created solutions are working fine in your local Git repository when using this fresh VS 2015 Update 1 on your client?


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Monday, February 8, 2016 9:27 AM
    Moderator
  • Hi John,

    only this one solution is affected, since I moved to fresh VS 2015 Update 1 installation on a brand new Windows 10 machine.

    Many other solutions as well as new ones are just fine.

    Originally, 2 years ago, this solution was TFS "source controlled". Once the problem started I removed all the remaining *.vssscc files and Scc* settings from solution file. It did not help and I am completely clueless.

    And again: I do not use TFS at all. It is a local Git repository!

    Thank you for your attention.

    Tomasz




    Monday, February 8, 2016 10:07 AM
  • Hi Tomasz,

    Thank you for coming back. To find which has cause this error, could you please share this solution to us? I want to test it to find the solution.

    Thanks.


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Tuesday, February 9, 2016 1:56 AM
    Moderator
  • Tingting,

    how do I share my solution?

    In any case, I recreated the solution from scratch and the issue seems gone away.

    Thanks,

    Tomasz

    Wednesday, February 10, 2016 12:30 PM
  • Hi Tomasz,

    I glad to hear that your issue has been solved and thank you for sharing your experience here.It will be very beneficial for other community members having the similar questions.

    All your participation and support are very important to build such harmonious/ pleasant / learning environment for MSDN community.



    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.


    Thursday, February 11, 2016 1:55 AM
    Moderator