locked
ObjectDataSource 'ObjectDataSource1' could not be found. RRS feed

  • Question

  • User2001647265 posted

    I uploaded my PWS into goDaddy.com web hosting and tested it out.

    Encountered an error of

    ObjectDataSource 'ObjectDataSource1' could not be found. <?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" /><o:p></o:p>Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

    Exception Details: System.InvalidOperationException: The type specified in the TypeName property of ObjectDataSource 'ObjectDataSource1' could not be found.

    Source Error: <o:p></o:p>

    An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below. <o:p></o:p>


    Stack Trace: <o:p></o:p>

    <o:p> </o:p>

    [InvalidOperationException: The type specified in the TypeName property of ObjectDataSource 'ObjectDataSource1' could not be found.]<o:p></o:p>   System.Web.UI.WebControls.ObjectDataSourceView.GetType(String typeName) +1329383<o:p></o:p>   System.Web.UI.WebControls.ObjectDataSourceView.ExecuteSelect(DataSourceSelectArguments arguments) +1866<o:p></o:p>   System.Web.UI.DataSourceView.Select(DataSourceSelectArguments arguments, DataSourceViewSelectCallback callback) +17<o:p></o:p>   System.Web.UI.WebControls.DataBoundControl.PerformSelect() +149<o:p></o:p>   System.Web.UI.WebControls.BaseDataBoundControl.DataBind() +70<o:p></o:p>   System.Web.UI.WebControls.FormView.DataBind() +4<o:p></o:p>   System.Web.UI.WebControls.BaseDataBoundControl.EnsureDataBound() +82<o:p></o:p>   System.Web.UI.WebControls.FormView.EnsureDataBound() +163<o:p></o:p>   System.Web.UI.WebControls.CompositeDataBoundControl.CreateChildControls() +69<o:p></o:p>   System.Web.UI.Control.EnsureChildControls() +87<o:p></o:p>   System.Web.UI.Control.PreRenderRecursiveInternal() +50<o:p></o:p>   System.Web.UI.Control.PreRenderRecursiveInternal() +170<o:p></o:p>   System.Web.UI.Control.PreRenderRecursiveInternal() +170<o:p></o:p>   System.Web.UI.Control.PreRenderRecursiveInternal() +170<o:p></o:p>   System.Web.UI.Control.PreRenderRecursiveInternal() +170<o:p></o:p>   System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +2041<o:p></o:p>

    Also, I already modified my webconfig file as the forum advised.

    Please help and advice.

    Thanks,

    TJ

    Thursday, January 15, 2009 9:18 AM

All replies

  • User1275632693 posted

    Which Page generated this error?

     

    Friday, January 16, 2009 4:20 PM
  • User2001647265 posted

    The errors msg did not tell which pages.   I'm newbie to ASP.NET 2.0.

    My plan is to create my personal page by utilizing Personal Site Starter Kit.    I was able to compile and run in my local machine after modified the front end.

    Would be possible to get it run on the hosting server?

     

    Thanks,
    TJ

    Tuesday, January 20, 2009 3:29 PM
  • User1275632693 posted

    Hi,

     I would think one could do that, I have my site up and running on a host as well, the thing for me though is that I am not using Godaddy, so you need to dig a little more in these forums for folks who had issues setting it up on GoDaddy.

     

     

     

    Tuesday, January 20, 2009 3:51 PM
  • User2001647265 posted

    Hi, I retested on my Visual Studio 2005 environment and it compile and run. Then, I uploaded to discountASP web hosting.  However, I did not subscribe SQL Server 2005.

    When I run it, I received Global.asax errors:

    Server Error in '/' Application.

    A network-related or instance-specific error occurred while establishing a connection to SQL Server. The server was not found or was not accessible. Verify that the instance name is correct and that SQL Server is configured to allow remote connections. (provider: SQL Network Interfaces, error: 26 - Error Locating Server/Instance Specified)

    Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

    Exception Details: System.Data.SqlClient.SqlException: A network-related or instance-specific error occurred while establishing a connection to SQL Server. The server was not found or was not accessible. Verify that the instance name is correct and that SQL Server is configured to allow remote connections. (provider: SQL Network Interfaces, error: 26 - Error Locating Server/Instance Specified)

    Source Error:

    Line 5:  	void Application_Start(object sender, EventArgs e) {
    Line 6:  		SiteMap.SiteMapResolve += new SiteMapResolveEventHandler(AppendQueryString);
    Line 7:  		if (!Roles.RoleExists("Administrators")) Roles.CreateRole("Administrators");
    Line 8:  		if (!Roles.RoleExists("Friends")) Roles.CreateRole("Friends");
    Line 9:  	}


    Source File: e:\web\dbaindones1\htdocs\Global.asax    Line: 7

     Can you advice on this?

    How to make it works?

     

    Tuesday, January 20, 2009 4:56 PM
  • User1275632693 posted

    Hi,

    If you are not using SQL 2005, what SQL data source are you using? 

     I think some folks have got it working using MS ACCESS but as far as I remember you need to have an SQL database behind this site for it to work.

    If you cant use SQL 2005, dig in the forums to see how others might have adapted it to use MS ACCESS.

     

     

    Tuesday, January 20, 2009 5:25 PM
  • User-185907525 posted

    I get exactly the same fault with Visual Studio 2008. It runs correctly while in Visual Studio but when published in the  'LocalHost' site on the same computer I get the error. I can get it to work if I don't use objects but connect directly to the SQLServer database. - Why....

    Thursday, January 14, 2010 8:24 PM