locked
DefaultThemesOff=true is not quite Windows Classic RRS feed

  • Question

  • I'd really like to select the Windows Classic theme in my answer file, but the documented way doesn't quite work.

    Setting Themes.DefaultThemesOff=true supposed specifies that the Windows Classic visual style will be displayed.  However, it always ends up a little bit off because all of the fonts are set to BOLD for some unknown reason.  If I later select the Windows Classic theme from the "Personalize" settings, the fonts get corrected.  Ergo, something is amiss with this setting.

    I've tried selecting the Windows Classic theme by setting Themes.ThemeName=Windows Classic and then by Themes.ThemeName=classic.theme and some other variations, but none have worked.  At this point, I'm thinking of just copying the appropriate settings out of a working registry and using regedit to slam them in as a FirstLogonCommand and let the second boot (or logon?) display the correct theme (hopefully.)

    But there must be a better (i.e. "correct") way to get this to work.  Has anyone found it?

    Thursday, March 1, 2012 9:09 PM

All replies

  • Hi Steve,

    I got the same problem and I never found the way to set it using ICE. I finally used an OOBE FirstLogonCommand with the VBS script below and it's working fine. I know that's not exactly what you're looking for but may be better than modifying a lot of keys in the registry.

    Hoping it could help you

    SynchronousCommand: cscript SetClassicTheme.vbs

    SetClassicTheme.VBS (below)

    Set WshShell = WScript.CreateObject("WScript.Shell")

    WshShell.Run "rundll32.exe %SystemRoot%\system32\shell32.dll,Control_RunDLL %SystemRoot%\system32\desk.cpl desk,@Themes /Action:OpenTheme /file:""C:\Windows\Resources\Ease of Access Themes\classic.theme"""

    Wscript.Sleep 5000
    WshShell.AppActivate("Desktop Properties")
    WshShell.Sendkeys "%FC"
    WshShell.Sendkeys "{F4}"

    Friday, March 9, 2012 10:17 AM