locked
FastCGI Possible Errors RRS feed

  • Question

  • User174756505 posted

    We're running into a problem but we're not sure if it's FastCGI but it seems to be. When max instances is set higher than 0 then we see this issue more often but that can't be fully confirmed but even at 0 it still seems to have an issue, just not as much.

    What happens is randomly a site (perhaps 1 out of 100 requests) will come back with a 500 error. We changed FastCGI to respond as 200 but the headers we're getting back when that happens are:

    ------------------------------------------------------------------------
    HTTP/1.1 500 Internal Server Error
    Cache-Control: no-store, no-cache, must-revalidate, post-check=0, pre-check=0
    Pragma: no-cache
    Content-Length: 0
    Content-Type: text/html
    Expires: Thu, 19 Nov 1981 08:52:00 GMT
    Server: Microsoft-IIS/7.5
    Set-Cookie: PHPSESSID=r98o9k42bds92ce2po34r92eu2; path=/
    X-Powered-By: PHP/5.3.8
    X-Powered-By: ASP.NET
    X-Powered-By: ARR/2.5
    X-Powered-By: ASP.NET
    Date: Fri, 21 Oct 2011 23:07:30 GMT
    Connection: close
    ------------------------------------------------------------------------

    How do we track if this is a FastCGI issue. Keep in mind this only happens with PHP sites and PHP is not throwing an error in the PHP log file. We're running Windows 2008 R2 and PHP 5.3.8, FastCGI 1.2 and WinCache 1.2.614.

    Friday, October 21, 2011 7:19 PM

All replies

  • User-1672167363 posted

    Hi,

    What kind of PHP code is being run ?

    Have you looked at how many sessions files are currently saved ?

    Martin

     

    Saturday, October 22, 2011 12:00 AM
  • User-1672167363 posted

    This Topic IIS 5.0.x IIS 6.x and  FastCGI Possible Errors:

    Personal Suggestions and options:

    Personal suggestion: Report the issues and problems to the PHP Bugs site https://bugs.php.net/ with version and Windows information.

    Personal Suggestion: You can open a Support  case with Microsoft Support   http://support.microsoft.com/ the Experts

    will help gathering the required information to try and reproduce and isolate and test to pinpoint the root causes.

    Please contact Microsoft Support for more advise. http://support.microsoft.com/

    Regards, 

    Martin

    Monday, January 30, 2012 9:09 AM
  • User-1672167363 posted

    Hello,

    Forums IIS 5.0 & 6.0 FasCGI Topic and Questions :FastCGI Possible Errors, How do we track ?, if this is a FastCGI issue.?

    "Keep in mind, "this only happens with PHP" sites and PHP" "is not throwing an error in the PHP log file."

    "We're running Windows 2008 R2"

     and "PHP 5.3.8", "FastCGI 1.2" and "WinCache 1.2.614."

    We're running into a problem : but we're not sure if it's

    FastCGI but it seems to be.

    When max instances is set higher than 0 then we see this issue more often

    but that can't be fully confirmed

    but even at 0 it still seems to have an issue, just not as much.

    What happens is randomly a site (perhaps 1 out of 100 requests) will come back with a 500 error.

    We changed FastCGI to respond as 200

    but the headers we're getting back when that happens are:

    Please update this information.

    Regards,

    Martin

     

     

     

    Friday, February 3, 2012 9:42 AM