locked
Visual Studio "Pin is required to establish a connection" RRS feed

  • Question

  • I'm getting a weird error from Visual Studio after a fresh install on a clean system.


    Today my computer was getting groggy so I decided to reinstall the computer (Win10) this is exactly what I did


    1) Backed up using a batch program I wrote which compresses the dragged on directory using 7zip and renames it "folders name( dd/mm @ hh:mm)", creates 2 txt files with data for ftp commands, opens an ftp connection to my webserver, uploads the zip, then uploads to same zip to my nas and then to my sd card, the batch deletes the zip from temp and the text files, everything said it performed normally.


    2) I went to reset my pc and reset everything and deleted all files


    3) After Reinstalling I downloaded 7zip and visual studio with all the addons in the tick box list at the beginning of the installation, except I noticed it has windows phone 10 emulators this time.


    4) unzipped my work from the SDHC


    5) Opened in VS, VS asked me to login so I did everything loaded in normally


    6) Plugged In my phone (Lumia 930 WP10) clicked start debugging


    and I got this popup A PIN is required to establish a connection with the remote device. Please enter the PIN to pair the Device


    I have never seen this error, and as far as I can tell no one else has, that's why I have written in detail what I did to get it, the only post I can find says it is in the debugging properties so to set it to no authorisation but that is for a raspberry pi using VS and that option is not there or anywhere within VS


    the phone does not have a pin, or can I find a single setting anywhere on the phone or VS.


    I did however come across a setting in the phone that allows you to connect to your phone in the browser on a computer via its ip and remotely control the phone and access all the data via the browser

    Image For Error In VS
    The Phone Remote from a browser (If anyone is curious)

    UPDATE*** no matter what I do, I CAN run any of the windows phone 10 emulators, but VS CANNOT detect any emulators other than 8.1 emulators

    • Edited by David Zocchi Monday, December 7, 2015 2:29 PM Quick Update
    Sunday, December 6, 2015 5:35 AM

Answers

  • PROBLEM SOLVED**

    I went to programs & features, clicked visual studio community edition, and clicked repair, after it finished it said there was a problem installing the windows 10 SDK (v XX.XX.XX), so I went to

    https://dev.windows.com/en-US/downloads/windows-10-sdk

    I noticed the version number on the website to be higher, so I installed the SDK manually using the download link and presto it works :)

    • Proposed as answer by Fred Bao Tuesday, December 8, 2015 3:26 AM
    • Marked as answer by Fred Bao Wednesday, December 16, 2015 7:19 AM
    Monday, December 7, 2015 10:04 PM

All replies

  • I have the same question. I've tried entering the pairing key from the Device discovery, tried removing authentication from the Device portal, and tried my pin from my phone. Nothing so far.
    Sunday, December 6, 2015 4:55 PM
  • Hello David,

    >>and I got this popup A PIN is required to establish a connection with the remote device. Please enter the PIN to pair the Device

    From this exception message, it seems the phone is locked by the PIN code, do you have a try to input your PIN code to see if you could unlock it?

    Also, from your steps, you seems do a rollback from your original system installation environment. I guess this may cause some problem, and recommend you to download a refresh VS install package and install it to see if you could get it work.

    Regards.


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Monday, December 7, 2015 3:02 AM
  • I tried with pin I even added a lock screen pin to the phone to try it and nothing,

    my system before was completely fine with VS

    here is what I did

    1) Pressed Windows Key

    2) type reset

    3) clicked reset this PC

    4) clicked get started

    5) clicked remove everything (which reinstalls it to a bare clean system with the latest updates)

    then after I went straight to the Microsoft site and downloaded visual studio 2015 community edition, I ran the installer and selected all the packages I required as I usually do, like I said except this time there are more options regarding windows phone 10. everything installed fine.

    Monday, December 7, 2015 2:28 PM
  • I have just hard reset the device, still getting the same error

    Monday, December 7, 2015 2:33 PM
  • PROBLEM SOLVED**

    I went to programs & features, clicked visual studio community edition, and clicked repair, after it finished it said there was a problem installing the windows 10 SDK (v XX.XX.XX), so I went to

    https://dev.windows.com/en-US/downloads/windows-10-sdk

    I noticed the version number on the website to be higher, so I installed the SDK manually using the download link and presto it works :)

    • Proposed as answer by Fred Bao Tuesday, December 8, 2015 3:26 AM
    • Marked as answer by Fred Bao Wednesday, December 16, 2015 7:19 AM
    Monday, December 7, 2015 10:04 PM
  • Try my solution
    Monday, December 7, 2015 10:08 PM
  • Maybe a faster solution than restore Windows or repair VS:
    I made it work with the following steps:

    1. Turn the developer mode off on the phone and switch to "Only install Apps from Store"
    2. Plug the phone's USB connection
    3. Restart the phone
    4. Restart your PC
    5. Start Visual Studio
    6. Connect the Phone
    7. Try to debug the app on your phone, if Visual Studio does say anything else than "You have to put the phone into Sideload mode" (analogous), start over with step 1.
    8. Put the phone into sideload mode (not developer mode) and try again to debug, now the same message should show up like in step 7.
    9. Switch your phone into developer mode

    Now the deploying process should work without any trouble. If not try the steps (maybe with some variations) again. I don't know where the problem is, but the above steps worked for me, but I don't know whether all steps are necessary, report back if you can leave one out. This solution does helps permanently, sometimes the problem comes up again. I think don't unplug the phone while debugging, helps to let the problem occur less often.

    Friday, January 22, 2016 12:04 PM