locked
VS2010 : Unable to start debugging Cannot locate Microsoft Internet Explorer RRS feed

  • General discussion

  • Hello,

    i have created a simple silverligth project and when i tried to start debugging i had this errror :

    "Unable to start debugging.

    Cannot locate Microsoft Internet Explorer."

    i have searched on the internet and i have found two solutions:

    The first one :

    "Navigating to HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\App Paths I found that theiexplore.exe key was missing. So here's what I did:

    1. Added the iexplore.exe key to the  registry.
    2. Changed the (Default) REG_SZ value to C:\Program Files\Internet Explorer\iexplore.exe 
    3. Added a new REG_SZ value called Path and set it to C:\Program Files\Internet Explorer
    4. Restarted my Visual Studio.

    "

    This doesn't work, the iexplore.exe key is here.

    (default) REG_SZ C:\Program Files (x86)\Internet Explorer\IEXPLORE.EXE

    Path C:\Program Files( x86)\Internet Explorer;

    the second is to right click into the aspx file and select "Browse With ..", and set internet explorer as default.

    Is already that ...

    I have launched older project in silverlight, and i have the same problem ...

    i think  i got this bug because i have installed IE9 ...

    anyone can help me ?

    Thanks

    Wednesday, August 29, 2012 11:05 AM

Answers

  • found the answer :

    "Navigating to HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\App Paths I found that theiexplore.exe key was missing. So here's what I did:

    1. Added the iexplore.exe key to the  registry.
    2. Changed the (Default) REG_SZ value to C:\Program Files\Internet Explorer\iexplore.exe 
    3. Added a new REG_SZ value called Path and set it to C:\Program Files\Internet Explorer
    4. Restarted my Visual Studio.
    Wednesday, September 5, 2012 12:14 PM

All replies

  • http://social.msdn.microsoft.com/Forums/en-US/silverlightinstall/thread/e8fe1cce-ac00-453a-8e29-7ee664328b23//1

    http://social.msdn.microsoft.com/Forums/en-US/silverlightinstall/thread/50f158c5-da36-453d-a703-2ee38c07c990//1

    http://social.msdn.microsoft.com/Forums/de-DE/silverlightde/thread/4af869e2-2c7c-4168-952b-b22ba7c92b0f/

    Thursday, August 30, 2012 5:28 AM
  • Hello,

    thanks for you reply, 

    but i have already found those link before posting my post and that doesn't work for me ...

    Thursday, August 30, 2012 5:42 AM
    1. If your Windows is 64 bit OS, you should have to update HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\App Paths\IEXPLORE.EXE values, Changed the (Default) REG_SZ value to C:\Program Files(x86)\Internet Explorer\IEXPLORE.EXE;
    2. Try to reinstall IE;
    3. Try to use FireFox or Chrome or Opera instead of IE;
    4. WoVS Default Browser Switcher: http://visualstudiogallery.msdn.microsoft.com/bb424812-f742-41ef-974a-cdac607df921/ 
    5. http://www.hanselman.com/blog/HowToChangeTheDefaultBrowserInVisualStudioProgrammaticallyWithPowerShellAndPossiblyPokeYourselfInTheEye.aspx 
    Tuesday, September 4, 2012 10:37 AM
  • Hello,

    Thanks for you reply ...

    i have tried each step => i got the same issue : Cannot Locate Microsoft Internet Explorer.

    I don't understand, when i change the default browser (right click, browse with ... set Firefox or Chrome as default) he wanna open Internet Explorer !

    if in debuggers, i uncheck Silverlight : he open the browser with no problem , but i can't debug my silverlight project ...

    Why Silverlight wanna open internet explorer everytime ... i really don't understand :s

    Wednesday, September 5, 2012 11:10 AM
  • found the answer :

    "Navigating to HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\App Paths I found that theiexplore.exe key was missing. So here's what I did:

    1. Added the iexplore.exe key to the  registry.
    2. Changed the (Default) REG_SZ value to C:\Program Files\Internet Explorer\iexplore.exe 
    3. Added a new REG_SZ value called Path and set it to C:\Program Files\Internet Explorer
    4. Restarted my Visual Studio.
    Wednesday, September 5, 2012 12:14 PM