locked
Publish infopath filler (2007) with code RRS feed

  • Question

  • Published from client computer.(fully trusted/digital cert added)

    1. working from with my computer.

    2. not working with other user. (error msg as below)

    3. there is repeated table. when there is extra row other than one row.
       (if form has only one row: has no problem of submitting to SP)

    *error message*

    InfoPath cannot submit the form.

    The form cannot be submitted because it contains validation errors. Errors are marked with either a red asterisk (required fields) or a red, dashed border (invalid values).

       at Microsoft.Office.InfoPath.Internal.MomExceptionHelper.ExecuteDataConnectionAction(OMCall d)

       at Microsoft.Office.InfoPath.Internal.WebServiceConnectionHost.Execute()

       at rndfilter.FormCode.btnSendChanges_Clicked(Object sender, ClickedEventArgs e)

       at Microsoft.Office.InfoPath.Internal.ButtonEventHost.OnButtonClick(DocActionEvent pEvent)

       at Microsoft.Office.Interop.InfoPath.SemiTrust._ButtonEventSink_SinkHelper.OnClick(DocActionEvent pEvent)

    Tuesday, September 18, 2012 1:15 PM

Answers

  • Dear Emir,

    I have infopath2010 installed my computer.  But When I published, I selected the compatibility as "infopath 2007 filler".

    So it was working fine with my computer.

    Today I tested it through users.

    User with 2007 infopath installed: Not working. "validation error"

    User with 2010 infopath installed: Working fine.

    I have no idea whey error message shows as "validation error" for infopath 2007 user.

    Also I have no idea why it only working with user with infopath 2010 installed even though when form publsihed with compatibiliy of "infopath 2007 filler".

    But at least I'm so gald to find out the root cause.

    I really appreciate your sincere response which I was able to narrow down the problem.

    Friday, September 21, 2012 8:02 PM

All replies

  • Hi,

    There may a field in the form that has the validation problem, maybe a required field is still blank, string with incorrect format given to a date control, or an incorrect user given to people picker control. This field may in another view, or in a hidden section. If you are unable to fine it directly from the form, please remove fields one at a time from a form copied from the original form until you find the problem field.

    Thanks & Regards,
    Emir


    Emir Liu

    TechNet Community Support

    Wednesday, September 19, 2012 7:28 AM
  • Your response is much appreciated.

    Here is my argument.

    But how come it is working fine with my login. (Site owner/designer).

    Only validation error captured when normal user (contribution access) tried to submit.

    Even for normal user, it is working fine when only one row submitted.

    FYI(There is webservice connection. add /update/delete item onto other sharepoint list(but same site) from this infopath form repeating table.)

    Wednesday, September 19, 2012 8:22 PM
  • Hi,

    Do the fields within the repeating table marked as "cannot be blank"? We you inserted a new row, have you given value to this new row?

    Or is there any rules added to repeating table, which is used to clean/change another field?

    I still want to suggest you to remove field on at a time and test with the normal user.

    Thanks & Regards,
    Emir


    Emir Liu

    TechNet Community Support

    Thursday, September 20, 2012 10:50 AM
  • Dear Emir,

    I have infopath2010 installed my computer.  But When I published, I selected the compatibility as "infopath 2007 filler".

    So it was working fine with my computer.

    Today I tested it through users.

    User with 2007 infopath installed: Not working. "validation error"

    User with 2010 infopath installed: Working fine.

    I have no idea whey error message shows as "validation error" for infopath 2007 user.

    Also I have no idea why it only working with user with infopath 2010 installed even though when form publsihed with compatibiliy of "infopath 2007 filler".

    But at least I'm so gald to find out the root cause.

    I really appreciate your sincere response which I was able to narrow down the problem.

    Friday, September 21, 2012 8:02 PM