locked
Getting 407 Proxy Authentication Required on startup RRS feed

  • Question

  • Hi there!

    Got myself a brand new computer with Windows 8.1 Pro installed. The old one had Windows 7. Running VS 2013 on both machines on the corporate network, which uses a proxy for internet access, I notice one slight difference in behaviour:

    On the new machine, every single time I start VS, I get this popup:

    ---------------------------
    Microsoft Visual Studio
    ---------------------------
    HTTP code 407: Proxy Authentication Required ( The ISA Server requires authorization to fulfill the request. Access to the Web Proxy filter is denied.  )
    ---------------------------
    OK   
    ---------------------------

    I notice that in the background, the start page of VS states "Announcements: Updating the news channel...". That doesn't change until I click ok on the popup. After that, the news list is populated like there never was a problem.

    So why is it that VS feel the need to inform me of this proxy problem, when it's obviously not a problem once I click OK? It's becoming quite annoying to see this popup every single time I start VS. And it never shows up on the Win7 computer, using the same proxy server (and settings). Instead, it's displayed as a single line notification in the Output window.

    How can I make VS "use the proxy settings immediately", instead of "after first access failure" which seems to be the current setting?

    (The workaround mentioned on http://stackoverflow.com/questions/13717815/visual-studio-error-407-proxy-authentication-required does not apply, since I do not get a popup asking me to submit my credentials, so please don't ask me to try that one.)

    • Edited by Magnus Hedberg Thursday, November 20, 2014 10:16 AM Apparantly, you can add images while editing, but they do not publish...
    Thursday, November 20, 2014 10:15 AM

Answers

  • Hello Magnus Hedberg,

    Have you tried configure the following sites:

    "app.vssps.visualstudio.com; app.vssps.visualstudio.com:443; visualstudio.com; live.com; microsoft.com; *.accesscontrol.windows.net"

    in your proxy to make them allowed for you to access?

    Or you may try the solution listed on MSDN here:

    http://msdn.microsoft.com/en-us/library/dn771556.aspx

    Can the issue be solved?

    Regards,



    Barry
    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    • Marked as answer by Barry Wang Friday, November 28, 2014 4:43 AM
    Friday, November 21, 2014 2:59 AM