none
Enabling Developer Mode RRS feed

  • Question

  • Hello --

    I am trying to enable Developer Mode in Visual Studio 2019 so that I can create UWP apps.  I am running VS as an administrator, but I still see the message "Sign in as an administrator to change these settings" on the "For developers" settings page, and the radio buttons are greyed out.  What do I need to do, therefore, to enable developer mode?

    -- John Seydel

    Tuesday, August 6, 2019 7:47 PM

All replies

  • This:

    is tied to your Windows user account.

    This user account must be identified as an administrator by Windows:

    If your Windows user account is an administrator, try going through the settings to get to this. You can get to this via Settings -> Update and Security -> For Developers.


    This is a signature. Any samples given are not meant to have error checking or show best practices. They are meant to just illustrate a point. I may also give inefficient code or introduce some problems to discourage copy/paste coding. This is because the major point of my posts is to aid in the learning process.

    Tuesday, August 6, 2019 10:01 PM
  • Hi John,

    Welcome to the MSDN forum.

    #l am running VS as an administrator but l still see the message "Sign in as an administrator" to change these settings" on the "For developers" settings page

    >>l agree with Darran's answer. That warning message reminds you to use the administrator account in the current operating system rather than use administrator mode to run vs.

    So please check your account in the settings and change to use administrator account to try again.

    Any feedback will be expected.

    Best Regards,

    Perry



    MSDN Community Support Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com

    Wednesday, August 7, 2019 2:46 AM
  • Hi John,

    Did your issue solve? Did you use a administrator account and follow our steps to enable developer mode? 

    If our reply is helpful for you to solve this issue, please remember to mark as answer.

    If your issue still exists, please feel free to let us know. We are willing to help you further.

    Best Regards,

    Perry


    MSDN Community Support Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com


    Friday, August 9, 2019 6:40 AM
  • Hi John Seydel,

    Sorry for bothering you.

    Did you use administrator account to sign-in your machine? Or you could try to add your account into admin group.

    Hope it could help you.

    Best Regards,

    Dylan


    MSDN Community Support Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com

    Wednesday, September 4, 2019 7:35 AM