locked
getting 400 bad request error while executing csom code in timer function app RRS feed

  • Question

  • Hi,

    I am unable to execute csom code in timer function app and I am getting 400 bad request

    error after executing Execute query statement. The code was executing in visual studio code with out any errors

    and please let me know why I am getting this issue. The am trying to connect a different tenant site.

    Thanks

    Azad


    Razvi444

    • Moved by Femisulu-MSFT Tuesday, October 2, 2018 2:39 AM better suited here
    Sunday, September 30, 2018 3:57 PM

All replies

  • Hi Razvi444 Did the deployment succeed? Could you indirectly share your app name please? Moreover, are you able to share more specific info with any private details omitted? Perhaps, this post could be of help..

    Tuesday, October 2, 2018 5:09 AM
  • Hi,

    I am not creating and deploying the app through visual studio. I am directly executing the code in azure itself in timer function in the file run.csx, here I am doing normal authentication with out passing access token and using SharePoint online credentials statement by passing hard coded username and securestring password and facing the issue. Is there any cross domain issue because my site belongs to another tenant with different domain. I tracked logs and found that whenever calls getting to my tenant, request is rejecting with 401 error. Do I need to use any access token for successful authentication. Please suggest me tthe possible way.

    Thanks


    Razvi444

    Tuesday, October 2, 2018 8:34 AM