none
Access 2016 - Unable to add a value in a DropDown field. RRS feed

  • Question

  • I have an Access Database 2016 in SharePoint under Office 365. Our users access

    the dB via OneDrive for Business. For months it has worked perfectly. Today, one

    of the users requested a 4th value to become available in a dropdown field called

    "MilitaryBranch". Currently, the MilitaryBranch field has these values: "None";

    "Army";"Navy";"Coast Guard". The "Marines" need to be added to the list. See Exhibit 1.

    I accessed  the dB via SharePoint, clicked on the IntakeForm, selected "Design View", r-clicked on the Militarybranch dropdown field, selected 'Edit Item List", added "Marines" in the list, clicked oK, and the following message appeared: "The linked table has been changed on the server. Your last entered row will not be saved. Copy and paste your last entered row to a temporary file, then synchronize the linked table with the server by  right-clicking on the link table, choosing More options and clicking Refresh List". See Exhibit 3. .  Whaaaat? In what kind of temporary file? In Notepad? Also, under "Database Tools" > Relationships >  The tables are available, but r-clicking on the Intake table does not display an option called "More", nor a "Refresh List" option is avail anywhere. I went ahead and tried something else.

    I r-clicked on the IntakeTable, r-click on "MilitaryBranch" and to my surprise it is a ‘Short Text' field instead of a Lookup Wizard field. See Exhibit 1.1. It does not let me change the data type to a lookup wizard field. A warning comes up which reads : "Microsoft SharePoint Foundation does not support this data type changed". See Exhibit 2. Why? . I did the same change months ago in one of those two tables and it worked.

    Would any of the readers know why It doesn't let me add the MilitaryBranch list of options? Or a way to add the value “Marines” I need in the MilitaryBranch field?

    Thanks.

    TempDavid


    Tuesday, July 24, 2018 9:24 PM

All replies

  • Hello TempDavid,

    Is there anyone else linked to the access database while you are trying to adding the forth item?

    If you copy the access database in the SharePoint document and then try to add item to the copied database, will the issue still occur?

    Best Regards,

    Terry


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Wednesday, July 25, 2018 9:55 AM
  • Hello Terry. 

    Thanks for the reply!

    Reg. your 1st question: No. Nobody accesses the dB while I am working on it. Specially when I am in Design mode and I need to make changes to the dB. I always ensure the other users (only 2) are not in, are not even logged in. I ensure they have closed the the database and access 2016.

    Reg. your 1st question: The dB already resides in SharePoint, within a sub-sub folder called IntakeDB. When I need to make a change in the design (i.e. Adding an extra value to a drop-down list), I go to SharePoint , r-click on the form, Design view,  r-click on the field, select 'Edit Item List' and try to add "Marines" to the list of options and it fails as mentioned in the original posting. The issue still occurs when you attempt the operation directly from SharePoint.

    And Yes, I have made a copy of the dB, place it in the root of C: .....same results.

    I truly hop I have addressed you questions completely, if you have any other question, please let me know and I will provide the answer right away.

    Thanks.
    David.

    Wednesday, July 25, 2018 3:19 PM