none
Error: This could be due to the service endpoint binding not using the HTTP protocol RRS feed

  • Question

  • Hi, I'm pretty new with WCF Service Application. Today I tried for the first time to retrieve data to bind a DropDownList and I'm getting this error. The Entity Object is retrieved right but when I return it as a List I'm getting the error. I've read tons of solutions and nothing seem to work.

    I have edit the maxArrayLength, maxBytesPerRead added <dataContractSerializer maxItemsInObjectGraph="1000000" /> and nothing...

    This is my web.config:

    <?xml version="1.0" encoding="utf-8"?>
    <configuration>
      <configSections>
        <!-- For more information on Entity Framework configuration, visit http://go.microsoft.com/fwlink/?LinkID=237468 -->
        <section name="entityFramework" type="System.Data.Entity.Internal.ConfigFile.EntityFrameworkSection, EntityFramework, Version=4.4.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" requirePermission="false" />
      </configSections>
      <system.web>
        <compilation debug="true" targetFramework="4.0">
          <assemblies>
            <add assembly="System.Data.Entity, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" />
          </assemblies>
        </compilation>
      </system.web>
      <system.serviceModel>
        <bindings>
          <basicHttpBinding>
            <binding name="NewBinding0" maxBufferSize="2147483647" maxBufferPoolSize="2147483647"
              maxReceivedMessageSize="2147483647">
              <readerQuotas maxDepth="2147483647" maxStringContentLength="2147483647"
                maxArrayLength="2147483647" maxBytesPerRead="2147483647" maxNameTableCharCount="2147483647" />
            </binding>
          </basicHttpBinding>
        </bindings>
        <behaviors>
          <serviceBehaviors>
            <behavior>
              <!-- Para evitar revelar información de los metadatos, establezca el valor siguiente en false antes de la implementación -->
              <serviceMetadata httpGetEnabled="true" />
              <!-- Para recibir detalles de las excepciones en los fallos, con el fin de poder realizar la depuración, establezca el valor siguiente en true. Para no revelar información sobre las excepciones, establézcalo en false antes de la implementación -->
              <serviceDebug includeExceptionDetailInFaults="true" />
              <dataContractSerializer maxItemsInObjectGraph="2147483646"/>
              <serviceThrottling maxConcurrentCalls="3000" maxConcurrentSessions="3000" maxConcurrentInstances="3000"/>
            </behavior>
            
          </serviceBehaviors>
          <endpointBehaviors>
            <behavior name="MyBehavior">
              <dataContractSerializer maxItemsInObjectGraph="1000000" />
            </behavior>
          </endpointBehaviors>
        </behaviors>
        <serviceHostingEnvironment multipleSiteBindingsEnabled="true" />
      </system.serviceModel>
      <system.webServer>
        <modules runAllManagedModulesForAllRequests="true" />
        <!--
            Para examinar el directorio raíz de la aplicación web durante la depuración, establezca el valor siguiente en true.
            Establézcalo en false antes de la implementación para evitar revelar información sobre la carpeta de aplicación web.
          -->
        <directoryBrowse enabled="true" />
      </system.webServer>
      <connectionStrings>
        <add name="GestionPersonalEntities" connectionString="metadata=res://*/GestionPersonal.csdl|res://*/GestionPersonal.ssdl|res://*/GestionPersonal.msl;provider=System.Data.SqlClient;provider connection string=&quot;data source=DIEGOPOLANCO-HP\SQLEXPRESS;initial catalog=GestionPersonal;integrated security=True;MultipleActiveResultSets=True;App=EntityFramework&quot;" providerName="System.Data.EntityClient" />
      </connectionStrings>
      <entityFramework>
        <defaultConnectionFactory type="System.Data.Entity.Infrastructure.SqlConnectionFactory, EntityFramework" />
      </entityFramework>
    </configuration>

    Wednesday, May 15, 2013 8:52 AM

Answers

All replies