locked
Viewbox/calendar not displaying RRS feed

  • Question

  • I add a calendar to a project, run it, it displays. However, I want the calendar bigger but it doesn't seem possible to resize it by itself, so I stumbled across embedding it in a viewbox, which allows you to easily resize it on the artboard.

    But when I run the project, I just get the Silverlight loading image going round and round. Is there some magic you have to do with a viewbox to get it to run properly?

    Thanks

     

    Friday, April 29, 2011 2:20 PM

Answers

  • I just verified on my own machine that setting a property such as SelectedDate="2011-05-01" causes the problem you are seeing. Changing it to 05/01/2011 works.
    Friday, April 29, 2011 5:59 PM
    Moderator

All replies

  • Is there an error in the lower left of the browser window when this happens?

    Could you run it in VS under debug mode to see if there is an error occuring?

    Friday, April 29, 2011 3:16 PM
    Moderator
  • XamlParseException occured

    Failed to create a 'System.Nullable`1[[System.DateTime, mscorlib, Version=2.0.5.0, Culture=neutral, PublicKeyToken=7cec85d7bea7798e]]' from the text '2011-05-01'. [Line: 77 Position: 123]

    VS is pointing at the InitializeComponent in  Public Sub New()

     

    I had set the DisplayDateStart for May 1st in Blend...

     

    Friday, April 29, 2011 3:54 PM
  • No error in browser window, in this case, IE9

    Error message is from VS debugging...

    Friday, April 29, 2011 5:07 PM
  • Since the error is on parsing the date, have you tried changing the date? Is it possibly an ambiguous date reference?

     

    Friday, April 29, 2011 5:54 PM
    Moderator
  • I just verified on my own machine that setting a property such as SelectedDate="2011-05-01" causes the problem you are seeing. Changing it to 05/01/2011 works.
    Friday, April 29, 2011 5:59 PM
    Moderator
  • The Blend IDE won't take the leading '0', but entering the date in that format in the .xaml worked.

    Thanks!

    Friday, April 29, 2011 7:28 PM
  • You probably don't need the leading 0, I just typed it out that way.
    Friday, April 29, 2011 7:43 PM
    Moderator