locked
aspnet_wp.exe eating up my server RRS feed

  • Question

  • User1707316043 posted
    I'm a newbie with .net and with my first app, I have an issue with aspnet_wp.exe using all my CPU. The page where this is happening has been working fine during development for two weeks, then yesterday it starts to hang. This seems to happen when updating or inserting data into a database. Other pages access the database without a problem. When I run taskmgr.exe I find aspnet_wp.exe at 99% What have I changed to make this start happening? Thanks in advance
    Wednesday, June 30, 2004 8:19 AM

All replies

  • User-1000197047 posted
    Do you have your code in a version control system? Is so, check what has changed there since it was working. If you have the change isolated but can't figure out the reason then you could do a post with the before/after change and then someone here might be able to help.
    Wednesday, June 30, 2004 11:51 AM
  • User-158764254 posted
    check your SQL server to see if you have some Blocking going on...
    Wednesday, June 30, 2004 12:29 PM
  • User1707316043 posted
    Sorry to have bothered you guys, I need a spell check in my connection string
    Wednesday, June 30, 2004 11:23 PM
  • User-58325672 posted
    ::Other pages access the database without a problem. AND ::Sorry to have bothered you guys, I need a spell check in my connection string why don't you use one connection string if it's the same DB? you didn't need a connectionstring per page or form, one is enough ;)
    Thursday, July 1, 2004 7:22 AM
  • User-158764254 posted
    yup! put the connection string someplace central. we use web.config we have a config class to access all web.config settings since the connection string has the pwd, we encrypt it before putting it in the web.config. the config class automatically decrypts it when we need it.
    Thursday, July 1, 2004 8:57 AM
  • User1707316043 posted
    Yeah, I just read about that this morning in one of the books I'm using to learn this. Thanks for the help.
    Thursday, July 1, 2004 9:35 AM