locked
Cannot make changes to existing config rules in Application Configuration Center RRS feed

  • Question

  • Hi,

    I went to the Application Configuration Center this morning to add access to the Condition type. I've been doing this a lot over the last two weeks as I work on an application and realize I forgot something. I have one online rule and one offline rule. Currently they have the same list of permissions except that the offline rule is read only and the online rule is for all permissions.

    Today when I check the box for Condition and then click save I get an error : "Authorization rule name is required." It's never been required before (I'm not using options rules), but it's no problem. So I added a name and a why string and clicked save and it complains that "Authorization rule name can't be greater than 16 characters." no problem. I submit with a shorter name. Now I get the original error - "Authorization rule name is required."

    I'm not sure what to do here. Am I doing something wrong?

    Friday, August 21, 2009 6:57 PM

Answers

  • I have changed the rule names in Application Configuration Center for your Application ID and now you can go ahead, edit the existing rules and create new rules.
    -Mahesh
    Tuesday, August 25, 2009 8:00 PM

All replies

  • Hello Daniel, I could reproduce the issue provided with your steps. I am contacting our Development team and will get back to you ASAP.
    -Mahesh
    Friday, August 21, 2009 7:19 PM
  • Can you please check whether all the existing rules have rule names, if not give a rule name to each of the existing rules and then try creating a new one.

    It requires that not only the new rule has the name but that all other rules have a name. If only the default rule exists, it will not allow you to create a new rule until you edit the default rule and provide a name.


    -Mahesh
    Friday, August 21, 2009 8:09 PM
  • Thanks, Mahesh, for looking into this.

    I only have one rule in offline and one in online. I guess these are the default rules - one for offline and online? Neither of them have a name. I am not able to save either of those rules right now, even to give them a name. I am not trying to create a new rule.
    Friday, August 21, 2009 8:32 PM
  • Are you not able to edit the existing rules and provide a rule name?

    Can you please give your Application ID?
    -Mahesh
    Friday, August 21, 2009 8:58 PM
  • That's correct. I can't edit my existing rules and they currently have no name.

    The app id is: 88d83747-c2a8-48d0-b2be-923f1e89f6e9


    Friday, August 21, 2009 9:41 PM
  • As you can only update one rule at a time, and the config center will not let you update a rule unless all rules have a name.

    Can you delete any one rule either in offline or online and give a name to the remaining existing rule. Then re-add other rules with names.


    -Mahesh
    Friday, August 21, 2009 10:25 PM
  • I'm in the middle of building a feature, so I'm going to hold off on taking the ~30 min hit right now and try your suggestion later today. Thanks for your help! I'll let you know how it goes.
    Friday, August 21, 2009 10:48 PM
  • When I try to delete one of my rules I get the following message: "Authorization rule name is required. Deleted a rule."

    It sounds like maybe it worked (and the rule has been removed from the page), but when I refresh the page, the rule is still there.

    So, I can't edit OR delete my rules. Perhaps someone on your end can name them for me?
    Tuesday, August 25, 2009 1:54 AM
  • These are the steps to be followed.

    1. If more than one rule exists without a name, you must delete all but one rule.
    2. Note down which rules were deleted so that they can be recreated later.

    3. First delete the rule in OfflineAccess tab. (As you delete the rule in OnlineAccess tab and when you refresh, the rule still exists)
    4. Update the rule in OnlineAccess with a rule name.
    5. Recreate the deleted rules, giving each a name as you recreate them.

    Hope this helps.


    -Mahesh
    Tuesday, August 25, 2009 4:31 PM
  • When I delete my OfflineAccess rule, it fails - same problem as the OnlineAccess rule - "Authorization rule name is required. Deleted a rule." When I re-visit the OfflineAccess tab, the rule is still there.
    Tuesday, August 25, 2009 5:35 PM
  • I have changed the rule names in Application Configuration Center for your Application ID and now you can go ahead, edit the existing rules and create new rules.
    -Mahesh
    Tuesday, August 25, 2009 8:00 PM
  • That worked. Thank you!
    Tuesday, August 25, 2009 8:10 PM