locked
Failure sending mail: The specified string is not in the form required for an e-mail address.Mail will not be resent RRS feed

  • Question

  • Hi All,

    I am trying to create a new subscription and getting the error

    Failure sending mail: The specified string is not in the form required for an e-mail address.Mail will not be resent

    Its just two emails seperated by (;)

    I tried the following 

    1. Please navigate to RSReportserver.config file: <drive:>\Program Files\Microsoft SQL Server MSSQL.n\Reporting Services\ReportServer\RSReportserver.config.
    2. Backup the RSReportserver.config file before we modify it, open the RSReportserver.config file with Notepad format.
    3. Set SendEmailToUserAlias to False. 
    4. Set DefaultHostName to the Domain Name System (DNS) name or IP address of the SMTP server or forwarder.
    5. Save the file.

    Please advice as what else i have to do.the report has four drop down parameters as well and i have set them to select all 

    Thanks


    • Edited by AmyBI Tuesday, February 20, 2018 12:55 AM
    Tuesday, February 20, 2018 12:53 AM

All replies

  • Hi AmyBI, 

    After set the configuration file, you could re-start the reporting service to check this issue. You need to make sure the addresses are all correct. In addition, if you separate send these subscriptions will it work or not.

    Or you could use data-driven subscription to check this issue, type all receiver addresses in dataset, then choose get value from dataset to check whether it works or not.

     And you could check whether there is any error information in log file, if there is, please inform me.

    Best Regards,
    Zoe Zhi


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Wednesday, February 21, 2018 1:55 AM
  • Check ssrs error log..Are able send email using SSMS ?

    try send test mail from cmd also. check relay is working.

    https://stackoverflow.com/questions/18652001/send-mail-via-cmd-console


    https://social.technet.microsoft.com/wiki/contents/articles/37872.sql-server-installation-on-centos-linux.aspx

    Wednesday, February 21, 2018 4:08 AM
  • Is this a standard or data driven subscription? 

    Please Mark This As Answer if it solved your issue
    Please Vote This As Helpful if it helps to solve your issue
    Visakh
    ----------------------------
    My Wiki User Page
    My MSDN Page
    My Personal Blog
    My Facebook Page

    Wednesday, February 21, 2018 5:12 AM
  • scheduled with four drop down parameters.

    Thanks

    Friday, February 23, 2018 12:03 AM
  • Thanks Zoe,

    Its scheduled one. All valid email id ( both mine) admin on the box

    Friday, February 23, 2018 12:36 AM
  • Hi AmyBI,

    I don't understand what you mean, did it work? Could you please inform me in details?

    Thanks for your understanding and support.
    Best Regards,
    Zoe Zhi


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Friday, February 23, 2018 6:41 AM
  • scheduled with four drop down parameters.

    Thanks

    i repeat

    Is it standard or data driven subscription?

    https://www.databasejournal.com/features/mssql/report-subscription-in-ssrs-2008-r2.html


    Please Mark This As Answer if it solved your issue
    Please Vote This As Helpful if it helps to solve your issue
    Visakh
    ----------------------------
    My Wiki User Page
    My MSDN Page
    My Personal Blog
    My Facebook Page

    Friday, February 23, 2018 6:53 AM
  • standard thanks.

    Now i am getting new error message on one of the parameters

    Failure sending mail: Default value or value provided for the report parameter 'DISPOSITION' is not a valid value.Mail will not be resent.

    The parameters are  set to select multiple values and selected all by default.

    • Edited by AmyBI Tuesday, February 27, 2018 11:58 AM
    Tuesday, February 27, 2018 11:52 AM
  • Hi AmyBI

    According to your error information, please check whether you change the parameter in parameter setting in Report Manager. Or whether you use snapshot subscription? You could try to re-deploy the report on Report Manger, with default setting and create standard subscription to check this issue. 

    You could refer to this post and this post for details.

    Best Regards,
    Zoe Zhi


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Thursday, March 1, 2018 6:57 AM