locked
Cannot change the network profile

    Question

  • I used to be able to see my desktop computer from the Slate PC when connected to my home wireless network. For some reason, I cannot do it anymore. The sharing settings show that I am using the Guest or Public profile. Changing the Network discovery and File and printer sharing options doesn't help. I tried recreating the profile by removing the connection profile and reconnecting to the network again. I made sure I selected the option to be able to share files, but I still have the Guest or Public profile assigned to this connection.

    Has anyone had this problem? Is there a solution?

    Wednesday, October 19, 2011 10:54 PM

Answers

  • I just want to report that I have reinstalled the OS, and I can again see and connect to my desktop computer from my Slate PC. However, to my surprise, Advanced sharing settings still show Gest or Public (current profile) as the active profile, and I don't know how to change it, except I don't really need to. What's even more surprising is that network discovery and file and printer sharing are both turned off. I guess they don't affect that functionality if I try to connect to a computer I know by name rather than browse the network.

    Thanks to everybody for your help!

    • Marked as answer by Vadim Klishko Wednesday, October 26, 2011 3:48 AM
    Wednesday, October 26, 2011 3:48 AM

All replies

  • I have some additional information to the problem I reported above: When I turn on Network discovery and File and printer sharing, I can see my Slate PC from my desktop computer running Windows XP and connect to it, but I still cannot see or connect to my desktop from the slate.
    Thursday, October 20, 2011 5:37 AM
  • Is your Windows Developer Preview computer joined to a Homegroup? Starting from Windows 7, the new sharing scheme is used. By default, you won't be able to access files shares on Windows 7/8 from your obsolete Windows XP system. You need to change file sharing options first.

    Have a look at Control Panel\Network and Internet\Network and Sharing Center\Advanced sharing settings

    Please take this info as-is. I am not sure I am correct here.


    Well this is the world we live in And these are the hands we're given...
    Thursday, October 20, 2011 8:32 AM
  • I don't think Windows XP settings are causing the problem, because:

    1. It used to work before.

    2. I can access my Windows 8 shares from my Windows XP computer. It is the opposite that doesn't work.

    3. Somehow, my network profile changes don't get applied on Windows 8.

    Thursday, October 20, 2011 6:40 PM
  • Hey Vadim Klishko,

     

    What changes are you making to your network profile that aren't getting applied? Please provide steps if possible so that we can see if we experience the same issue.

     

    Look forward to hearing back from you.


    Steven
    Sunday, October 23, 2011 2:47 AM
    Moderator
  • Thanks for your interest. Here are the steps:
     
    A. Checking the network profile.
     
    1. Right-click the network icon in the system tray on the standard Desktop.
     
    2. Select Open Network and Sharing Center.
     
    3. Select Change advanced sharing settings in the task panel on the left.
     
    4. The next screen shows Guest or Public (current profile).
     
    This is what I do to change it:
     
    B. Changing the network profile
     
    1. Left-click the network icon in the system tray on the standard Desktop.
     
    2. Right-click on the currently connected network and select Remove connection profile.
     
    3. Left-click on it again and select Connect.
     
    4. Enter the security key and click OK.
     
    5. Select Enable sharing and connect to devices.
     
    Repeat steps in section A to see that nothing has changed.
    Monday, October 24, 2011 3:12 AM
  • I don't think Windows XP settings are causing the problem, because:

    1. It used to work before.

    2. I can access my Windows 8 shares from my Windows XP computer. It is the opposite that doesn't work.

    3. Somehow, my network profile changes don't get applied on Windows 8.


    I didn't say these are XP settings that are the culprit. You have to look for security settings in Windows Developer Preview.
    Well this is the world we live in And these are the hands we're given...
    Monday, October 24, 2011 7:00 AM
  • I didn't say these are XP settings that are the culprit. You have to look for security settings in Windows Developer Preview.
    I apologoize for my misunderstanding, Exotic Hadron. Thank you for clarification.
    Monday, October 24, 2011 6:09 PM
  • I just want to report that I have reinstalled the OS, and I can again see and connect to my desktop computer from my Slate PC. However, to my surprise, Advanced sharing settings still show Gest or Public (current profile) as the active profile, and I don't know how to change it, except I don't really need to. What's even more surprising is that network discovery and file and printer sharing are both turned off. I guess they don't affect that functionality if I try to connect to a computer I know by name rather than browse the network.

    Thanks to everybody for your help!

    • Marked as answer by Vadim Klishko Wednesday, October 26, 2011 3:48 AM
    Wednesday, October 26, 2011 3:48 AM
  • Hi, Vadim!

    Thanks for posting!

    Public profile means that anybody can access your files / shared resources on Windows Developer Preview and that's why network sharing is disabled. Can you access your shares from XP box via UNC paths?


    Well this is the world we live in And these are the hands we're given...
    Wednesday, October 26, 2011 2:16 PM
  • Can you access your shares from XP box via UNC paths?


    Yes, if I Turn on file and printer sharing in the Advanced sharing settings or if I change my current profile to Private.

    By the way, I did figure out how to change the network profile. When I open Network and Sharing Center (e.g., by right-clicking on the network icon in the system tray and selecting Open Network and Sharing Center), it will show my active network with a Private network or Public network link under the network name. If I click on it, it will open a window where I can select an option that will change the profile.

    Thursday, October 27, 2011 6:01 AM