none
2015 Update 3 - Application Property Page - Exception

    Question

  • I am running VS 2015 Update 3 Enterprise on Windows 7 64 bit.

    version

    Recently VS has started throwing this error when trying to view the Application properties tab.

    Error

    I have tried the following:

    1. Repair.
    2. devenv /SafeMode
    3. devenv /ResetSettings
    4. devenv /ResetAddin
    5. devenv /ResetSkipPkgs

    Any other suggestions.

    Regards.

    Tuesday, September 20, 2016 9:47 AM

All replies

  • Hi CQuest,

    According to your description, your Visual Studio works fine before but has this error from one day, is it right?

    I suggest you check whether there has any updates installed before this issue occurs from Control Panel -> Programs and Features -> View Installed Updates.

    Then please check the ActiveLog.xml under the path of %AppData%\Microsoft\VisualStudio\14.0. This file will log all operations when you operate Visual Studio. Whether there has any error log.

    In addition, is this issue occurs for all projects in Visual Studio? Please create a new project to check whether the new project also has this issue.

    Best Regards,
    Weiwei


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Thursday, September 22, 2016 5:25 AM
    Moderator
  • Hi CQuest,

    Do you have tried above troubleshooting steps and check the ActiveLog.xml file? Please tell us how is this problem going now?

    Best Regards,
    Weiwei


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Monday, September 26, 2016 9:12 AM
    Moderator
  • Hi Weiwei,

    There is no file called ActiveLog.xml on my PC.

    I have removed all updates for VS2015 and now it runs for a few seconds and closes again even when running in SafeMode.

    Regards,

    Chris.

    Monday, September 26, 2016 11:13 AM
  • Hi Chris,

    The ActiveLog.xml is stored in AppData folder, which is a hidden folder. Please confirm your File System is set as shown the Hidden files first. Then please turn on the Log switch for your Visual Studio and then re-operate your Visual Studio again.

    Best Regards,
    Weiwei


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Tuesday, September 27, 2016 9:25 AM
    Moderator
  • Hi Weiwei,

    My AppData folder was visible but there was no ActiveLog.xml file, however I have used the Log Switch command to create one.

    There are 1700 lines of XML but this section looks significant.


    Thursday, September 29, 2016 7:55 AM
  • Hi Chris,

    This line of message should be log when your Visual Studio closed after you uninstall all Updates for Visual Studio 2015.

    I suggest you install the Updates for Visual Studio 2015 again and then open the Properties window again to check whether there has any logs about the Properties exception.

    Best Regards,
    Weiwei


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Friday, September 30, 2016 6:04 AM
    Moderator
  • Hi Weiwei,

    I followed your advice, reinstalled update3, ran devenv /log and waited for a specific time, then loaded a basic windows forms application and displayed the application properties tab with the exception message showing.

    Looking at the log from the specific time there are no errors reported and nothing relating to properties or exceptions.

    Chris.

    Friday, September 30, 2016 9:48 AM
  • Hi CQuest,

    If there doesn't have any message in ActiveLog file, I suggest you check the Windows Event Viewer, whether there has any error information about devenv.

    In addition, is this issue occurs with all projects or just this specific project? Whether there has any issue in your project?

    Best Regards,
    Weiwei


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Wednesday, October 05, 2016 2:38 AM
    Moderator