none
emulator for my image RRS feed

  • Question

  • I've develop WinCe image for arm processor and now I haven't board for this image. BUt I must write apps for this OS. How Can I use device emulator to load this image and then test my apps in this emulator?
    Tuesday, July 31, 2012 9:11 AM

All replies

  • Absolutely, to a certain degree of course. Just add the emulator BSP to your OS Design and build selecting the emulator build configuration. Then configure the SDK (see the build menu) to include your emulator image and install the SDK on your machine. You can now use VS to develop your app on the emulator.

    Good luck,

    Michel Verhagen, eMVP
    Check out my blog: http://guruce.com/blog

    GuruCE
    Microsoft Embedded Partner
    http://guruce.com
    Consultancy, training and development services.

    Tuesday, July 31, 2012 9:33 AM
    Moderator
  • Hi.

    I've add BSP DeviceEmulator:ARMV4I and build it

    then add SDK

    Properties CPU Families I select my cpu family ARMV4I Confuguration Freescale imx233(my bsp)

    Propertie Emulation I select Device Emulatorr ARMV4I debug

    then buld SDK

    I have 2 warning

    Warning    1    Warning: The SDK that you are building is targeted toward managed development, but the OS design on which the SDK is based does not include SYSGEN_WCELOAD. This might prevent .NET runtime components from successfully downloading to the target device.        
     

    Warning    2    Warning: The SDK that you are building includes a Device Emulator run-time image configured to enable KITL. This might prevent application development tools from connecting to the target device.        

    I install SDK and Run DeviceManager. Select My Device and press Connect. Emulator start but I see only black screen. There are no descktop or any shell. Only black screen. What I do wrong?

    P.S. After few minutes emulator show me message: Cannot connect to device.


    • Edited by Artem Wednesday, August 15, 2012 2:49 PM
    Wednesday, August 15, 2012 2:39 PM
  • warning 1 :

    You have to include wceload.exe component (SYSGEN_WCELOAD) for installing cab file feature into emulator (ex. if you don't include .Net Compact Framework into OS image, Visual Studio will try to download the cab file into device for installing it).

    warning 2 :

    You have to disable KITL in Release configuration before build OS image and generate SDK. I think that black screen and the message "Cannot connect to device" are due to KITL, because Visual Studio can't connect to emulator via KITL. In this case you have to use Core Connectivity.

    Paolo.


    Paolo Patierno

    Wednesday, August 15, 2012 3:03 PM
  • I try disable KITL but emulator not load

    Have you any idea?

    Thursday, August 16, 2012 6:25 AM
  • First try to get the Device emulator working by following the steps in the blog post.
     
    Once you got the emulator working,you can use another VS instance to develop and deploy the application to the emulator.
     
    Thursday, August 16, 2012 7:00 AM