none
Questions about the DeviceLock area in Policy CSP in Win 10 RRS feed

  • Question

  • I tried set the devicelock policies as below:

    <Replace><CmdID>9</CmdID><Item><Target><LocURI>./Vendor/MSFT/Policy/Config/DeviceLock/DevicePasswordEnabled</LocURI></Target><Meta><Format xmlns="syncml:metinf">int</Format><Type xmlns="syncml:metinf">text/plain</Type></Meta><Data>0</Data></Item></Replace><Replace><CmdID>10</CmdID><Item><Target><LocURI>./Vendor/MSFT/Policy/Config/DeviceLock/AllowSimpleDevicePassword</LocURI></Target><Meta><Format xmlns="syncml:metinf">int</Format><Type xmlns="syncml:metinf">text/plain</Type></Meta><Data>1</Data></Item></Replace><Replace><CmdID>11</CmdID><Item><Target><LocURI>./Vendor/MSFT/Policy/Config/DeviceLock/MinDevicePasswordLength</LocURI></Target><Meta><Format xmlns="syncml:metinf">int</Format><Type xmlns="syncml:metinf">text/plain</Type></Meta><Data>4</Data></Item></Replace><Replace><CmdID>12</CmdID><Item><Target><LocURI>./Vendor/MSFT/Policy/Config/DeviceLock/MinDevicePasswordComplexCharacters</LocURI></Target><Meta><Format xmlns="syncml:metinf">int</Format><Type xmlns="syncml:metinf">text/plain</Type></Meta><Data>1</Data></Item></Replace><Replace><CmdID>13</CmdID><Item><Target><LocURI>./Vendor/MSFT/Policy/Config/DeviceLock/DevicePasswordExpiration</LocURI></Target><Meta><Format xmlns="syncml:metinf">int</Format><Type xmlns="syncml:metinf">text/plain</Type></Meta><Data>0</Data></Item></Replace><Replace><CmdID>14</CmdID><Item><Target><LocURI>./Vendor/MSFT/Policy/Config/DeviceLock/DevicePasswordHistory</LocURI></Target><Meta><Format xmlns="syncml:metinf">int</Format><Type xmlns="syncml:metinf">text/plain</Type></Meta><Data>0</Data></Item></Replace><Replace><CmdID>15</CmdID><Item><Target><LocURI>./Vendor/MSFT/Policy/Config/DeviceLock/MaxDevicePasswordFailedAttempts</LocURI></Target><Meta><Format xmlns="syncml:metinf">int</Format><Type xmlns="syncml:metinf">text/plain</Type></Meta><Data>0</Data></Item></Replace><Replace><CmdID>16</CmdID><Item><Target><LocURI>./Vendor/MSFT/Policy/Config/DeviceLock/MaxInactivityTimeDeviceLock</LocURI></Target><Meta><Format xmlns="syncml:metinf">int</Format><Type xmlns="syncml:metinf">text/plain</Type></Meta><Data>0</Data></Item></Replace>
    But there are somethings confused me:

    1) The devicepassword enabled is not effect immediately, I must sign out then sign in and it will request to set the password. Not like in a phone device it will required to set the password immediately. Is this behavior  by design?
    2) As you see I set the MinDevicePasswordComplexCharactores as 1, and MinDevicePasswordLength as 4. But I can't set the password to "1qazs" nor "1qaz@". And the password "1qaz@WSX" is OK. Are there something wrong in my OMA-DM config?


    Will some body help me on this? Thank you.

    Thursday, July 30, 2015 5:27 PM