locked
CommVault to Azure issues RRS feed

  • Question

  • Hello,

    We have been issues backing up our files to the Azure container we have created to use with CommVault. Keep getting the resource is not available and that Azure is offline. When I check the dashboard I see that our containers are online. I was on the phone with CommVault support and did a test using the cloudtesttool and got an error message: Failed to check Container [container name] status, error: Error = 44037. I tried using both access keys and got the same error message. This was all working fine until Friday December 5th. 

    Anyone else having the same issue? Please let me know if you need any additional information

    Monday, December 8, 2014 6:47 PM

Answers

  • Hi

    Support has answered about it:

    "We do have a patch available to upgrade the OpenSSL version and address this issue.

     'WinX64_9.0.0B84_OpenSSL101i(46852)'"

    I'll try to find it

    Regards

    • Marked as answer by Manu Rekhar Sunday, December 14, 2014 2:38 AM
    Thursday, December 11, 2014 10:24 AM

All replies

  • Hi Fech,

    Is it possible to create a new container in Azure and check if the issue persists?? Please make sure you follow the steps provided in the following link:

    http://blogs.msdn.com/b/avkashchauhan/archive/2011/08/11/how-to-set-windows-azure-storage-provider-for-commvault-enterprise-backup-solution.aspx

    Also, please let know the datacenter region which you have opted to host your Azure Storage account.

    Regards,

    Manu Rekhar

    Tuesday, December 9, 2014 5:43 AM
  • Hello Manu,

    Thank you for the reply. I tried your suggestion but got Error: [Cloud] The server failed to do the verification. So the Folder 1 did not get created on Azure.

    We also have another account with information that CommVault was configured to talk to and we get the same error disk is offline. 

    When I try to resume the job I get the following error description:

    Failed to mount the disk media in library [Azure-Library] with mount path [Folder1] on MediaAgent [MediaAgent].   Reason: Failed to access the directory on the disk mount path. The volume may not be accessible. Advice: Make sure that the directory is accessible.

    Error occurred while processing chunk [Chunk#] in media [MediaVolume] for storage policy [Storage_Policy] copy [Cloud_Copy]:  Backup job [Job#]. Unable to setup the copy pipeline. .

    We are connecting to the East US data center

    I have attached the screen shot for your review when I tried to connect to the new container. For reason my account has not been verified, so I could not upload the screen shot.

    In addition, when I click to view the contents from one of the accounts I am able to see what is on Azure until Friday when we started having issues.


    • Edited by Fech Tuesday, December 9, 2014 3:31 PM additional info
    Tuesday, December 9, 2014 3:28 PM
  • Hi,

    We've got the same issue here with commvault. Same error and simptoms, but we started at the end of November. We've found that we have some more information:

    11/27 23:11:11 retryable error [44037], retry = 10, sleep for 10 second(s)
    11/27 23:11:21 == cURL Info: About to connect() to xxxxxxxxx.blob.core.windows.net port 443 (#0)
    11/27 23:11:21 == cURL Info:   Trying xxx.xxx.xxx.xxx...
    11/27 23:11:21 == cURL Info: TCP_NODELAY set
    11/27 23:11:21 == cURL Info: connected
    11/27 23:11:21 == cURL Info: Connected to xxxxxxxxxxx.blob.core.windows.net (xxx.xxx.xxx.xxx) port 443 (#0)
    11/27 23:11:21 == cURL Info: SSLv3, TLS handshake, Client hello (1):
    11/27 23:11:21 == cURL Info: SSLv3, TLS handshake, Server hello (2):
    11/27 23:11:21 == cURL Info: error:1411809D:SSL routines:SSL_CHECK_SERVERHELLO_TLSEXT:tls invalid ecpointformat list
    11/27 23:11:21 == cURL Info: Closing connection #0
    11/27 23:11:21 == cURL Info: SSL connect error
    11/27 23:11:21 CURL error, CURLcode= 35
    11/27 23:11:21 CVRESTBaseRemoteFile::SetRESTErrorCode() - Error: Error = 44037
    11/27 23:11:21 CVRESTBaseRemoteFile::SendRequest() - Error: Error = 44037
    11/27 23:11:21 GetRootFolderStatus() - Error: Error = 44037

    Looks that there's something related to ssl has changed. Our datacenter is Ireland

    Thanks

    Regards


    Wednesday, December 10, 2014 11:15 AM
  • Hello Alberto,

    Thank you for that reply, sounds like Azure, trying to fix the SSL 3.0 Poodle vulnerability may have cause CommVault to quit working? Maybe the reason why my quit on Dec 5 was due to their plan of making the change in staggering fashion starting with Europe, so maybe this week we will see the west coast of the US start having issues?

    Have you opened a case up with CommVault? I got a notice last night from my tech support person saying that there was another case similar to mine which requires more logs from me to have development take a look at it. 

    I am going to forward your information to CommVault tech support and see if they can get this resolved ASAP, I don't want to get too backed logged on my cloud copies. 

    Where did you get the logs in your reply from?

    Thanks,

    Wednesday, December 10, 2014 1:36 PM
  • Hi,

    We've opened a case, but support closed it because we delayed the answer. I'm opening a new one because as i can see i'm not alone in this issue.

    The log where you can find this messages is CloudTestTool.log  which resides on base folder of commvault in Media Agent which control Azure Library. In order to get this messages you have t execute CloudTestTool.exe from MA on Azure. It asks you for the data connection to the azure storage (account, keys...). Once you do this it'll try to connect to azure, and you'll get the log i have attached you.

    Hope it help us to point commvault support in the right direction. Please if you have any advance on the case post it.

    Many thanks

    Regards

    Wednesday, December 10, 2014 3:36 PM
  • Thank you Alberto!! I am attaching the log files and sending them to CV support. They are exactly the same as what you are getting! Hopefully with many more of these cases coming up they will get a fire lit under them to fix the issue, this is a huge problem!!

    Let me know if you need any more info to get your case going with CV.

    Wednesday, December 10, 2014 4:35 PM
  • I have found this on azure blog... i have attached it to my case too. It looks that SSLV3 support has ended over azure infraestructure. If Commvault relays on it... we'll need some kind of hotfix in order to get our libraries connect back:

    http://azure.microsoft.com/blog/2014/12/09/azure-security-ssl-3-0-update/

    Wednesday, December 10, 2014 5:14 PM
  • Thanks for that link. I have attached to my case as well. Waiting to hear from the engineer so they can get whatever logs they need. If you find anything else please post it here, and I'll do the same.

    Thank you

    Wednesday, December 10, 2014 6:24 PM
  • Hi

    Support has answered about it:

    "We do have a patch available to upgrade the OpenSSL version and address this issue.

     'WinX64_9.0.0B84_OpenSSL101i(46852)'"

    I'll try to find it

    Regards

    • Marked as answer by Manu Rekhar Sunday, December 14, 2014 2:38 AM
    Thursday, December 11, 2014 10:24 AM
  • Hello Alberto,

    Yup, I got a call from CV support and after the tech looked at a few things and I showed him a screen shot when I tried to configure a new cloud storage device he gave me the file and we applied it to my environment. I was going to wait to reply after it had a whole day of being able to back up. So far my Aux copy is still going and probably will until it gets caught up with the past few days. 

    Were you able to get the patch and apply it to your environment?

    Thursday, December 11, 2014 1:13 PM
  • Hi

    After applying Hotfix, backup started to work. This patch definitely solves the issue.

    Regards

    Friday, December 12, 2014 8:08 AM
  • Hello,

    That is great news! Glad it is working for you. Definitely this fix is what solves the problem! I am glad CV reacted fast and got it fixed in a timely matter.

    Friday, December 12, 2014 2:45 PM