none
Azure Virtual Machine backup: Backup failed with an internal error RRS feed

  • Question

  • We are using the 'Azure Virtual Machine' backup service. In Job Details, 'Take Snapshot' succeeds, but 'Transfer data to Backup vault' fails. Error Details says 'Backup failed with an internal error'. The backup fails in less than 10 minutes after starting.

    The initial backup of the VM succeeded, but all subsequent backups fail. Other VMs can backup to the same vault, using the same backup policy, with no issues. We tried (UnRegister, Register, Configure Protection) and (Stop Protection, Delete Backup Data, Configure Protection) with no improvement.

    Could it have anything to do with the backup extension? According to Job Details, the Snapshot succeeded, so I assume it's past the point where the extension is still active.

    In case it helps, the last failed Job ID is: 32936504-d0fc-48c4-b62c-a04dcff7792d

    Thanks,
    Robert


    • Edited by robert.yung Tuesday, April 28, 2015 6:03 PM
    Tuesday, April 28, 2015 6:00 PM

Answers

All replies

  • Hi Robert,

    Thanks for your post!

    I hope you have created the VM's and the Vault in the same region. In order to narrow down the issue could you please create a new backup vault, register the affected VM to it (in the same region) and try running the  backup.

    Let me know if that works!

    Regards,

    Sadiqh

    Tuesday, April 28, 2015 8:57 PM
    Moderator
  • According to Microsoft support, IaaS backups don't support VMs with more than 6 disks (for now). I have tested backups with VMs with up to 15 data disks and then it would fail when the 16th is attached. Unfortunately, removing the 16th data disk could not restore the backup functionality. So results may vary. Hopefully, these limitations will be resolved soon.
    Friday, May 1, 2015 7:29 PM