locked
IIS app pool freezes due to exception in web app RRS feed

  • Question

  • User720699657 posted

    I have an Asp.net website hosted on IIS server. IT has been found that sometimes users are  not able to login to the application. The Application does not throw any exception at all. Now when the admin recycles the application Pool, The website works Fine. Please help me in resolving the issue. Also Please not that this issue occurs on a regular basis. My IIS admin has checked the IIS and Database servers, they are working fine. According to them there may be a problem in the application itself which is causing this problem. I have checked the database connectivity as well, all the database connections are closed once thier job is done. Also the session objects are disposed off after session ends. Any help would be great

    Tuesday, October 1, 2013 8:46 AM

Answers

  • User-718146471 posted

    I'm thinking you might want to ensure your app has try/catch blocks unless you already have that in there. Without them, you will never know what's going on with the application itself. I would recommend using a logging component so anytime something goes bananas, you could have it send you a log email. The one I'm using is called ExceptionLogger and that one will log to different output points. You should be checking the Windows Event Viewer logs to see if they can provide you with some clues as to what is wrong.

    Exception Logger v2.0 http://www.doogal.co.uk/exception.php 

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Thursday, October 3, 2013 9:27 AM

All replies

  • User-718146471 posted

    Since this problem is heavy duty IIS, I strongly recommend you post this question to the IIS forums since you may get better traction there. http://forums.iis.net

    Tuesday, October 1, 2013 9:01 AM
  • User720699657 posted

    I have already posted in IIS Forum, But still got no solution. I dont know where to look now. my iis admin says that problem is with the application. I also checked the IIs logs as well, but still found no solution. Can this happen due to an exception in the web app? if yes how do i find it, cuz all me pages are working fine.

    Thursday, October 3, 2013 1:54 AM
  • User1196771204 posted

    hi there,

    have you had a chance to check the Windows Event Viewer for possible error? How about the CPU and RAM usage on your server? 

    Thursday, October 3, 2013 2:51 AM
  • User-718146471 posted

    I'm thinking you might want to ensure your app has try/catch blocks unless you already have that in there. Without them, you will never know what's going on with the application itself. I would recommend using a logging component so anytime something goes bananas, you could have it send you a log email. The one I'm using is called ExceptionLogger and that one will log to different output points. You should be checking the Windows Event Viewer logs to see if they can provide you with some clues as to what is wrong.

    Exception Logger v2.0 http://www.doogal.co.uk/exception.php 

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Thursday, October 3, 2013 9:27 AM