locked
Converting old projects and .NET dependencies.

    Question

  • Howdy. At Build and loving it. I'm attempting to load my C++ project with VS2011 but I get errors about not having .NET 4.0 on my Win8 Preview machine. I'd rather not install older versions as 4.5 is on here. And honestly I don't know why .NET 4.0 is required by my project. Back on my old box with VS2008, I don't have the framework required. Any help would be appreciated.

    Rich

    Wednesday, September 14, 2011 5:48 AM

Answers

  • @RLets - currently this is known with existing projects.  There is not a good workaround right now in the preview besides starting a new project and copying code over.  Sorry for the inconvenience.

    Wednesday, September 14, 2011 5:52 AM
  • Also, note that you should only see this if you are using Win8Express SKU and the issue has already been fixed internally. You should be able to load your old projects without any problem with Ultimate SKU. On Ultimate SKU, for VS2010 projects, you can even load them directly in VS2011 without conversion. Your native platform toolset will remian to be v100. You can upgrade them to v110.

     

    Li Shao, MSFT


    Li Shao
    Friday, September 16, 2011 6:28 AM

All replies

  • @RLets - currently this is known with existing projects.  There is not a good workaround right now in the preview besides starting a new project and copying code over.  Sorry for the inconvenience.

    Wednesday, September 14, 2011 5:52 AM
  • Okay. Thanks for the quick reply, Tim.
    Wednesday, September 14, 2011 5:54 AM
  • Also, note that you should only see this if you are using Win8Express SKU and the issue has already been fixed internally. You should be able to load your old projects without any problem with Ultimate SKU. On Ultimate SKU, for VS2010 projects, you can even load them directly in VS2011 without conversion. Your native platform toolset will remian to be v100. You can upgrade them to v110.

     

    Li Shao, MSFT


    Li Shao
    Friday, September 16, 2011 6:28 AM