none
Fidelity test with digital device... RRS feed

  • Question

  • We are developing a bluetooth audio driver, based off msvad. We are currently getting whql tests to pass. However, we are getting stuck on the Audio Fidelity Test.

    The test requires 48KHz pin format, but we only support 44.1KHz. We are also a digital device, so I'm not even sure why this test is being run.

    My only thought is that the jack is configured incorrectly, making whql think its an analogue jack, instead of a digital one.

    My jack description looks like this:

    static 
    KSJACK_DESCRIPTION JackDescBTDevice = 
    {
    	KSAUDIO_SPEAKER_STEREO,
    	0,
    	eConnTypeUnknown,
    	eGeoLocNotApplicable,
    	eGenLocPrimaryBox,
    	ePortConnJack,
    	TRUE
    };

    Is this the correct configuration for a bluetooth (digital) jack?

    Monday, January 28, 2013 6:08 PM

All replies

  • Hi,

    Try to disable the audio and run again the test.

    Let me know the result after you retest.

    Best Regards.

    Tuesday, January 29, 2013 1:06 AM
  • Here is the error I get:

    Error 1/29/2013 8:51:53.713 AM Endpoint does not support any acceptable 48 kHz format
    File:   testsrc\multimediatest\avcore\audio\multiapi\fidelity\proxy\format.cpp Line: 274
    Error Type:   BOOL
    Error Code:   0x0
    Error Text:   Error 0x00000000
    Error 1/29/2013 8:51:53.713 AM FidelityFormat failed: hr = 0x80004005
    File:   testsrc\multimediatest\avcore\audio\multiapi\fidelity\proxy\proxytest.cpp Line: 609
    Error Type:   BOOL
    Error Code:   0x0
    Error Text:   Error 0x00000000
    Error 1/29/2013 8:51:53.713 AM RunTestsOnEndpoint failed
    File:   testsrc\multimediatest\avcore\audio\multiapi\fidelity\proxy\proxytest.cpp Line: 431
    Error Type:   BOOL
    Error Code:   0x0
    Error Text:   Error 0x00000000
    Message 1/29/2013 8:51:53.713 AM No testable Capture audio endpoints in SUT -- need to log skips so job passes

    Tuesday, January 29, 2013 10:06 PM