locked
Access 2010 TreeView Arabic problem RRS feed

  • Question

  • hello,

    Im using access 2010

    when i try to load a data (language arab) from a recordset to a control treeview with vba acess 2010 , treeview display garbage instead of Arabic letters, and its not "?????"

    And yes i changed the non-unicode language into some Arabic language from the system locale.

    It was working fine before, but after many windows updates it became like this, i still have an old compiled accde file that i compiled before when everything was ok and it still shows the arabic letter good, but not the current accdb.

    Sunday, July 12, 2015 2:05 AM

Answers

  • Hi Waleed,

    Based on your description, all other forms shows Arabic character properly, it did not work when load a data (language arab) from a recordset to a control treeview with vba acess 2010? First, where and what you stored the data (language arab)? I suggest you check the data you stored. If the data did not store correctly, I assume it will not show correctly. Second, I suggest you load the data into other controls like textbox to check whether it is related with the specific control.

    >> i still have an old compiled accde file that i compiled before when everything was ok and it still shows the arabic letter good, but not the current accdb.

    Are they in the same PC? If not, I suggest you copy the worked accdb to the PC to check whether it could work correctly. It would be helpful if you could share us your steps to reproduce your issue.

    Best Regards,

    Edward


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.


    Monday, July 13, 2015 8:33 AM

All replies

  • hello,

    Im using access 2010

    when i try to load a data (language arab) from a recordset to a control treeview with vba acess 2010 , treeview display garbage instead of Arabic letters, and its not "?????"

    And yes i changed the non-unicode language into some Arabic language from the system locale.

    It was working fine before, but after many windows updates it became like this, i still have an old compiled accde file that i compiled before when everything was ok and it still shows the arabic letter good, but not the current accdb.

    by the way, all other forms shows arabic character properly.


    Sunday, July 12, 2015 2:27 AM
  • Hi Waleed,

    Based on your description, all other forms shows Arabic character properly, it did not work when load a data (language arab) from a recordset to a control treeview with vba acess 2010? First, where and what you stored the data (language arab)? I suggest you check the data you stored. If the data did not store correctly, I assume it will not show correctly. Second, I suggest you load the data into other controls like textbox to check whether it is related with the specific control.

    >> i still have an old compiled accde file that i compiled before when everything was ok and it still shows the arabic letter good, but not the current accdb.

    Are they in the same PC? If not, I suggest you copy the worked accdb to the PC to check whether it could work correctly. It would be helpful if you could share us your steps to reproduce your issue.

    Best Regards,

    Edward


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.


    Monday, July 13, 2015 8:33 AM