locked
Virtual machines cannot ping each other within same virtual network RRS feed

  • Question

  • I setup 6 virtual machines on the Azure and configured them in the same network (192.168.0.0-192.168.62), once i start 4 of them i can find each one got a IP address like this :

    Machine 1 : 192.168.0.4

    Machine 2 : 192.168.0.5

    Machine 2 : 192.168.0.6

    Machine 2 : 192.168.0.7

    i remote desktop to anyone of them and try to ping others, the ping cannot work, i tried to follow some guides to enable the ICMPv4&ICMPv6 for inbound traffic on the Windows firewall setting, but ping still cannot work.

    Since i have a SQL server installed on one machine, i tried to connect to it from other machines, but it cannot work either, the point is these servers can communicate before.(these virtual machines were deleted on time, and i re-create them from the disk. since disk are not deleted when you delete the virtual machine, everything on the virtual machine just like before)

    Waiting for your feedback.

    Many thanks


    William

    Wednesday, February 12, 2014 10:52 AM

Answers

  • Hi,

    Please make sure that all the VMs are in the same affinity group and the status of the VMs are running. If the VMs are not part of the same affinity group, they cannot communicate with each other.You can refer to the similar thread:

    Virtual Machine not communicating with each other

    Best regards,

    Susie


    • Marked as answer by Susie Long Tuesday, March 11, 2014 6:46 AM
    • Unmarked as answer by Susie Long Friday, March 21, 2014 2:34 AM
    • Edited by Susie Long Friday, March 21, 2014 2:54 AM edit
    • Marked as answer by Susie Long Friday, March 21, 2014 2:54 AM
    Wednesday, February 26, 2014 11:23 AM

All replies

  • I setup 6 virtual machines on the Azure and configured them in the same network (192.168.0.0-192.168.62), once i start 4 of them i can find each one got a IP address like this :

    Machine 1 : 192.168.0.4

    Machine 2 : 192.168.0.5

    Machine 2 : 192.168.0.6

    Machine 2 : 192.168.0.7

    i remote desktop to anyone of them and try to ping others, the ping cannot work, i tried to follow some guides to enable the ICMPv4&ICMPv6 for inbound traffic on the Windows firewall setting, but ping still cannot work.

    Since i have a SQL server installed on one machine, i tried to connect to it from other machines, but it cannot work either, the point is these servers can communicate before.(these virtual machines were deleted on time, and i re-create them from the disk. since disk are not deleted when you delete the virtual machine, everything on the virtual machine just like before)

    Waiting for your feedback.

    Many thanks


    William

    i tried to ping following address:

    127.0.0.1 - OK

    192.168.0.4 (on machine 192.168.0.4) - OK

    192.168.0.1 (gateway) -Failed

    now the problem is a little bit clear, i cannot ping the gateway and other machine. what's the actual problem ? these addresses are assigned automatically by the system.


    William

    Wednesday, February 12, 2014 3:57 PM
  • Hi,

    You will need to open File and Printer sharing option from firewall of these machines. Go to Control Panel-> System and Security->Allow a program through windows firewall->Select File and Printer Sharing checkbox for all networks.

    This process need to be done on all machine so that every machine can ping every other machine.

    Hope this helps.


    Mark As Answer if it helps you | My Blog

    • Proposed as answer by SergeyNorg Friday, June 16, 2017 10:54 AM
    Thursday, February 13, 2014 5:10 AM
  • Hi,

    In addition, it is not supported to ping the default gateway of a subnet.

    Since you can ping the loopback IP address, it means that TCP/IP is installed and correctly configured on the VM. What are the status of the VMs in the Windows Azure management portal? Please make sure that you have enabled inbound ICMP traffic on other VMs.

    Best regards,

    Susie

    Thursday, February 13, 2014 6:07 AM
  • Hi,

    In addition, it is not supported to ping the default gateway of a subnet.

    Since you can ping the loopback IP address, it means that TCP/IP is installed and correctly configured on the VM. What are the status of the VMs in the Windows Azure management portal? Please make sure that you have enabled inbound ICMP traffic on other VMs.

    Best regards,

    Susie


    i have already enabled the inbound ICMP, the point is not just Ping, the SQL server virtual machine also cannot be accessed by other virtual machines.

    William

    Friday, February 14, 2014 1:36 AM
  • You shouldn't necessarily need to configure the firewall in order to ping within your vnet. Whether you do or not will depend on your deployment configuration (and possibly method used to deploy).

    A few questions - how did you initially create the deployment and how are you now recreating the VMs (via portal or script)? Do any of the machines share the same Cloud Service? Do the NetBIOS/Machine names resolve to their correct IP addresses when you try pinging by name?

    Monday, February 17, 2014 2:36 PM
  • Hi,

    Please make sure that all the VMs are in the same affinity group and the status of the VMs are running. If the VMs are not part of the same affinity group, they cannot communicate with each other.You can refer to the similar thread:

    Virtual Machine not communicating with each other

    Best regards,

    Susie


    • Marked as answer by Susie Long Tuesday, March 11, 2014 6:46 AM
    • Unmarked as answer by Susie Long Friday, March 21, 2014 2:34 AM
    • Edited by Susie Long Friday, March 21, 2014 2:54 AM edit
    • Marked as answer by Susie Long Friday, March 21, 2014 2:54 AM
    Wednesday, February 26, 2014 11:23 AM
  • My Azure VM's are in Same Virtual Network but not able to ping each other.

    Enabling File and Printer sharing checkbox solved my issue.

    Thanks for the solution. 

    Best Regards,

    Ravi Theja Madisetty

    http://technoguns.com


    • Edited by tejaforever Monday, February 12, 2018 10:26 AM
    • Proposed as answer by Nirushi J Wednesday, February 28, 2018 6:53 AM
    • Unproposed as answer by Nirushi J Wednesday, February 28, 2018 6:53 AM
    Monday, February 12, 2018 10:24 AM