none
Issues with SSO using Dropbox

    Question

  • Recently I followed the steps in this article:

    https://docs.microsoft.com/en-us/azure/active-directory/active-directory-saas-dropboxforbusiness-tutorial

    I followed them step by step. After I get an error message "Sorry, but we're having trouble signing you in. We received a bad request.

    Additional technical information:
    Correlation ID: 389baeb4-f710-4b20-af8c-52974b036daa
    Timestamp: 2017-05-02 21:22:44Z

    AADSTS65005: Invalid resource. The client has requested access to a resource which is not listed in the requested permissions in the client's application registration. Client app ID: 97e0a159-74ec-4db1-918a-c03a9c3b6b81. Resource value from request: . Resource app ID: 00000002-0000-0000-c000-000000000000. List of valid resources from app registration: .

    I have gone through the settings on both sides multiple times and can't figure out why it is not working. Hoping you can shead some light on this issue.

    Tuesday, May 2, 2017 9:50 PM

All replies

  • Hey there - some helpful docs below 

    Please also make sure you are performing the app add using portal.azure.com. Also, please try deleting the application entry and starting again, fresh (sometimes a service principal can get corrupted). 

    If you still have problems, send me an email and I'll connect you with some folks. 

    All the best, 

    Adam. 

    https://docs.microsoft.com/en-us/azure/active-directory/application-sign-in-unexpected-user-consent-error

    https://docs.microsoft.com/en-us/azure/active-directory/active-directory-application-sign-in-content-map

    https://docs.microsoft.com/en-us/azure/active-directory/application-sign-in-problem-federated-sso-gallery


    Adam Steenwyk | Senior Program Manager | asteen@microsoft.com

    Wednesday, May 3, 2017 3:48 AM
  • Hi Adam

    Thank you very much for your reply. My gut feeling was to delete the app and start over but just needed a push because this is my first time attempting this set up. I will try that this afternoon and let you know how it goes.

    Thank you

    Stephen

    Thursday, May 4, 2017 6:43 PM
  • Hi Stephen,

    If deleting the app doesn't solve the problem. Please, in the AAD configuration for Dropbox. Add the Identifier value along with the Sign on URL. Dropbox uses one of the following values as Identifier:

    (1) Dropbox

    (2) http://www.dropbox.com

    If you don't know how to get the Identifier value, try with (1) first. This should solve the problem.

    Let me know how it goes.

    Thanks,

    Luis

    Friday, May 5, 2017 6:24 PM
  • Hi everyone,

    I'm having the same problem adding SSO for dropbox. I believe I have everything setup correctly, but am getting this error.

    Where do I add the Identifier values? I've added this in the new portal.

    Wednesday, June 21, 2017 1:06 PM
  • Adding "Dropbox" as the Identifier worked for me.
    • Proposed as answer by cpow99 Wednesday, July 19, 2017 8:00 PM
    Wednesday, July 19, 2017 8:00 PM