Cannot re-deploy app on machine with app installed from Store RRS feed

  • Question

  • I have submitted an app to the Store and it's now listed. I have installed it from the Store on the same machine used for development. I have un-install it so I can continue development, but now every time I try to deploy from VS I get an error:

    "DEP0700 : Registration of the app failed. Another user has already installed a packaged version of this app. An unpackaged version cannot replace this. The conflicting package is ..."

    Valentin Iliescu

    Tuesday, August 21, 2012 5:22 PM


  • Found the issue - apparently the error message contained the solution :) - The app was installed (from Store) on another account on the same machine. Once removed, VS deployment worked fine.

    Note that it was an issue only for VS deployment, creating and deploying the package using PowerShell worked fine.

    Valentin Iliescu

    • Marked as answer by Min ZhuMember Friday, August 31, 2012 2:54 AM
    Wednesday, August 22, 2012 3:52 AM