unable to find a version of the runtime to run this application .net framework initialization error RRS feed

  • General discussion

  • Hi

    I have an .exe  file built on, when tried to run this application i get an error as "unable to find a version of the runtime to run this application .net framework initialization error". I tried to reinstall the framework as well as i have upgraded the framework to the latest but in vein. still the same error.

    If at all i reinstall the application it starts in the first time and when ever i close the application and then restart the application then the error comes back and the application doesn't start. it ends with the same error.

    plz help me out with this


    Wednesday, November 25, 2009 9:18 PM

All replies

  • Try this:
    1. Check which .NET Framework versions are installed on your computer (use for example ClrVer.exe tool
    2. Check which .NET Fx version your application is built against (check app.exe.config file - scan for startup element).
    3. Create a small HelloWorld app in VB.NET and check if it has the same troubles as your app.

    Wednesday, November 25, 2009 9:59 PM
  • Hi Kanojwar,

    It is long time since the last reply, did you get useful information from above suggestions, or you still have any concern about this issue? Please let us know.




    Please remember to mark helpful replies as answers and unmark them if they provide no help.
    Monday, November 30, 2009 6:49 AM
  • Hi Eric

    Sorry got stuck in some other work.

    No I didn't find it useful in my case. Still the error pops up.

    can this might be with virus, As for one of the systems with same error i have to format it. then it solved.

    Vishal K
    Friday, December 4, 2009 4:44 AM
  • Why the advice was not useful? What was the result of #1-#3?

    And yes, it might be a virus, but more likely it is HW corruption or corrupted OS installation. I'd do this in addition:
        4. On how many machines did it happen?
        5. What is/was installed and uninstalled on those machines? Which OS?
        6. Try to repair all .NET Framework installations (incl. those which are part of OS).

    Friday, December 4, 2009 5:13 PM
  • hello all

    This is a problem that we all might face now or before...

    just think about a virus or a worm and nothing else..

    what u can do now is :

    go to system restore ( choose an old restore date before the problem exists) and restore your PC

    if the system RESTORED SUCCESFULLY (and i dont think it will) then try check if the problem resolved or not

    if the problem not resolved after PC restored (and this is just 10 %  to happen) 


    if the system could not be RESTORED}

    THEN we sure it's a windows error or a virus ( so clean up ur pc or better FORMAT) and setup evething again..\

    Iff ---- (after all mentioned) the problem still exists ( then I'm asking microsoft to do somthing about this issues) bcoz customers will not not trust programming with .NET anymore

    im also (even if have a good experience programming with .NET) i found that microsoft (even if it is the first and best) i found it failded until now to produce a fully compatable and portable IDE  (YET) ....

    this is weird microsoft!!!! 
    Friday, January 15, 2010 6:05 PM
  • I downloaded Player Editor (for EA Cricket 07) and then extracted all its contents in the same folder in which I have the game installed. Now, Everytime I click on Player Editor Icon (something like Ashes Trophy with ".ros 07" written on it), I get the following error.  I don't have Visual Basic and don't need it too. I get the when trying to run "Player Editor" for Cricket 07. Please Please reply to my query how can I solve it.

    "unable to find runtime version to run this application"

    What is the problem? Ho  can I solve it? Please reply as early as possible and in as simple terms and possible. Thanks...
    Thursday, March 3, 2011 7:41 AM
  • Contact support for Player Editor. It is possible that you do not have some prerequisites installed.


    Thursday, March 3, 2011 5:31 PM
  •  I had the exact same problem and searched all over the net for a solution ! it took me more than two day and in the end I found the solution ! 

    So here it comes people :D 

    Just download and install the old version of .net Framework ; in my case 2.0 and Voila Problem resolved :D

    Good Luck and keep Looking just don't gave up Yet :D

    Friday, May 25, 2012 4:09 PM