locked
Unable to connect to Witness after hardware failure (SQL 2005) RRS feed

  • Question

  • Hi All, 

    I do have 4 production servers for mirroring and 1 witness server as information below and all are working fine :- 

    (Principal : SQL2 , Mirror : SQL1 , Witess : WIT)

    (Principal : SQL4 , Mirror : SQL3 , Witess : WIT)

    Two days back there was a hardware failure on the switch which causing network issue and managed to replace a new one. Then I check on all the mirroring session, all databases are in SYNC except witness shows disconnected with the following error :- 

    Database mirroring connection error 4 'An error occurred while receiving data: '64(The specified network name is no longer available.)'.' for 'TCP://WIT:14999'.

    I tried to perform the following actions but still having the same results :-

    - Ping server WIT successfully

    - Able to telnet WIT's port 14999

    - Manage to connect to WIT through SQL management studio

    - Flush DNS on all the servers

    Is there any suggestion? Shall I reboot the witness or re-setting up the mirroring on witness? Thanks. 

    Wednesday, June 19, 2013 12:07 AM

Answers

  • Hi All, 

    I just solve it by restarting the SQL services in witness server. Thanks for all the advice.

    • Marked as answer by Harn Monday, June 24, 2013 11:44 PM
    Monday, June 24, 2013 11:44 PM

All replies

  • Try this, I recall something of that sort happening

    - Remove the witness instance from the mirroring session, apply the changes so that you are running without a witness i.e. in asynch or synch without witness

    - Delete the mirroring endpoint on your witness

    - Re-establish the mirroring scenario with the witness again, typically the setup should re-created the mirroring end point on the witness again.

    glk!

    • Proposed as answer by PrinceLucifer Monday, June 24, 2013 6:27 AM
    Wednesday, June 19, 2013 12:44 AM
    Administrator
  • It seems to be communications or DNS issue. Have you tried to telnet the port from all the servers?

    You can run netstat -a to check if servers listening to the port.

    Also check if domain account has sysadmin priviledges on all servers.

    and probably last option is to restart the witness server


    Please click the Mark as answer button and vote as helpful if this reply solves your problem

    • Proposed as answer by SM_122 Tuesday, July 16, 2013 7:19 AM
    Saturday, June 22, 2013 4:17 PM
  • Normally cycling the endpoint is enough in such Scenarios, but Amans solution of removing the witness and adding it again is also a safe way.
    Monday, June 24, 2013 6:26 AM
  • Hi All, 

    I just solve it by restarting the SQL services in witness server. Thanks for all the advice.

    • Marked as answer by Harn Monday, June 24, 2013 11:44 PM
    Monday, June 24, 2013 11:44 PM