locked
.SVC not responding (BizTalk) Timeouts RRS feed

  • Question

  • I am using .svc service. The service works fine for some time and again it stops responding. When we recycle the IIS App pool again it starts to work.
    After sometime again it timesout. While browsing on IE receiving below response.

    502 - Web server received an invalid response while acting as a gateway or proxy server.

    What is happening? Why is this happening ? How can we resolve this issue ?

    Reason101

    Friday, August 11, 2017 2:31 PM

All replies

  • Can you explain a little more the whole scenario?

    The messages from this SVC is consumed by an Orchestration, by Send Port, ..? 

    Is any external system invoked?

    ...

    Friday, August 11, 2017 2:54 PM
  • this is interaction of BizTalk with external system. Its a 2 way Send Receive port

    502 - Web server received an invalid response while acting as a gateway or proxy server.

    There is a problem with the page you are looking for, and it cannot be displayed. When the Web server (while acting as a gateway or proxy) contacted the upstream content server, it received an invalid response from the content server.


    Reason101

    Friday, August 11, 2017 3:08 PM
  • Hi,

    Have you looked on the IE proxy setting ? I would suspect you have a proxy configured on your IE which is causing you the problem .Let me know if removing proxy helps to resolve your issue


    If this answers your question please mark it accordingly. If this post is helpful, please vote as helpful by clicking the upward arrow mark next to my reply

    Tuesday, August 15, 2017 10:21 AM
  • Hello,

    If you are using ARR. Please follow this

    https://support.microsoft.com/en-us/help/2455129/fix-arr-does-not-route-requests-correctly-when-you-use-the-arr-module


    Ram

    Tuesday, August 15, 2017 2:26 PM
  • When the IIS is reset, the services work fine. But again after sometime the services go down. Is there anything gets locked ? Like Account getting locked ? Or darabase binded to this service is getting locked ? Any ideas anyone ?

    Reason101


    • Edited by Reason101 Friday, August 18, 2017 2:38 AM A
    Friday, August 18, 2017 2:37 AM
  • HI,

    We need more information.

    1) Are you trying to browse this service from a server which is not a BizTalk server?

    2) If yes, then check if you have a proxy configured on your web browser

    Also to answer your question if anything gets locked???

    Ideally when the account under which the application pool of your service is running gets locked then that particular app pool goes down and IIS then returns the 503 service not available error.

    What you need to check is if there is any proxy acting in between? are you by any chance running the fiddler on the environment from where you are accessing the service?


    Mandar Dharmadhikari

    Friday, August 18, 2017 5:51 AM
    Moderator