locked
Only administrators can access my database RRS feed

  • Question

  • I set up SQL Server 2008 on a server running Windows Server 2008. I can connect to the database from a client machine on the network but only if I log on as the administrator. Users cannot access the database. What should I do to allow all users on the system to connect to the database?
    Thursday, April 23, 2009 7:45 AM

Answers

  • Hi

    By default, all the logins in the domain are not configured on the SQL Server.

    Open SQL Server Management Studio
    Expand Security->Logins and Right Click and click the "New Login " dialog.
    Enter the details of the Login which you are trying to create and click "User Mapping" page and check the databases which the user needs access.
    Click ok to create the logins.

    User mapping setting automatically creates the users in the databases as well.
    You can restrict the user with limited permissions as well.

    Refer this articles on MSDN  for more information
    http://msdn.microsoft.com/en-us/library/aa337562.aspx
    http://msdn.microsoft.com/en-us/library/ms178316.aspx

    Thanks
    Sreekar
    Friday, April 24, 2009 1:12 PM

All replies

  • did u give permissions to users?

    try this..
    right click the server on SSMS;
    Select Properties;
    OPen Permissions and give SQL Connect permissions to the users.
    Regards,
    N_SQL
    Unfortunate is he who cannot gain a few sincere friends during his life
    ...and more unfortunate is the one who has gained them and then lost them (through his deeds).
    Thursday, April 23, 2009 10:29 AM
  • Hi,

    Check these link 

    http://www.mssqltips.com/tip.asp?tip=1440
    http://doc.ddart.net/mssql/sql70/ga-gz_4.htm

    I hope these links might be helpful


    Rajesh Jonnalagadda http://www.ggktech.com
    Thursday, April 23, 2009 10:43 AM
  • Not all the users on the system are available on the permissions page. I go to search then browse on the permissions page, and only find the administrators listed there. Is this maybe the way I installed SQL Server? Or maybe the way Windows Server is configured. The problem is our network administrator that set up the server has disappeared and I'm left to manage the server.

    Thursday, April 23, 2009 12:23 PM
  • Are u using remote desktop application?
    if yes then, goto control panel -> User Accounts,
    click "manage user Accounts"
    and add the users to the remote desktop users.

    Another solution could be:
    Control Panel-> Administrative tools -> Computer Management ->local Users and Groups
    Now u can add your users to different groups.


    Regards,
    N_SQL
    Unfortunate is he who cannot gain a few sincere friends during his life
    ...and more unfortunate is the one who has gained them and then lost them (through his deeds).
    Friday, April 24, 2009 5:13 AM
  • Thanks for the help, but I'm still struggling.

    The server is also a domain controller, which explains most of the problems I'm experiencing.

    >Are u using remote desktop application?
    >if yes then, goto control panel -> User Accounts,
    >click "manage user Accounts"
    >and add the users to the remote desktop users.

    Users on the system do not use remote desktops, although I did try to add all the users to the remote desktop users group, but did not make any difference.

    >Another solution could be:
    >Control Panel-> Administrative tools -> Computer Management ->local Users and Groups
    >Now u can add your users to different groups.

    Starting local Users and Groups starts the Active Directory Users and Computers.

    Friday, April 24, 2009 11:06 AM
  • Hi

    By default, all the logins in the domain are not configured on the SQL Server.

    Open SQL Server Management Studio
    Expand Security->Logins and Right Click and click the "New Login " dialog.
    Enter the details of the Login which you are trying to create and click "User Mapping" page and check the databases which the user needs access.
    Click ok to create the logins.

    User mapping setting automatically creates the users in the databases as well.
    You can restrict the user with limited permissions as well.

    Refer this articles on MSDN  for more information
    http://msdn.microsoft.com/en-us/library/aa337562.aspx
    http://msdn.microsoft.com/en-us/library/ms178316.aspx

    Thanks
    Sreekar
    Friday, April 24, 2009 1:12 PM