locked
Problems connecting nodes in different PCs! Problems with ServiceTutorial7! RRS feed

  • Question

  • Hello, 

    I have a problem when I try to run the Service tutorial 7 in to different PCs,I mean, when I use two different IPs to connect them. I've followed the service tutorial 7, and I've looked on the forums a lot, but it has not been enough to solve my problem. I also read this post:

    http://social.msdn.microsoft.com/Forums/en-US/roboticsdss/thread/9fc6999d-66c9-4ab2-8a7c-58d0c4516c59

    I though it  would be very helpful and very complete, but I continue with the problem.
    So, I'm going to explain my problem:

    I have the serviceTutorial4.manifest.xml in one computer(the "remote"), and the sertiveTutorial7.manifest.xml in the other(the "local"). 
    I can run the  serviceTutorial4.manifest.xml in the remote computer with dsshost /p:40000 /m:"serviceTutorial4.manifest.xml" and it works, I saw the node with http://localhost:40000 and I saw it was working well.

    Then, I start the node(as administrator) in the remote: dsshost /p:40000.
     then, in the local computer,  I edited the serviceTutorial7.manifest.xml, I change the Line<d:Service>http://localhost:40000/directory</d:Service> for
    <d:Service>http://IP-REMOTE:40000/directory</d:Service> , being IP-REMOTE as aaa.bbb.c.dd and the IP-LOCAL aaa.bbb.c.ee.

    I execute(as administrator also) dsshost /p:50000 /m:"serviceTutorial7.manifest.xml" . And here is my problem, the node start the servicetutorial7, start the localclock, and start the servicetutorial4!!
    And the Remote computer start nothing!! And I know the remote should start in the port 40000, the servicetutorial4, and the local should start the servicetutorial7 and the localclock, but not the serviceTutorial4! right?

    so, I think the problem is that the computers are not connecting...what do you think?  How can I solve this?

    Please,I appreciate any help...

    Wednesday, May 29, 2013 10:28 AM

Answers

  • thanks for the answer! but finally yesterday I achieved to run it in different PCs! I'm going to explain the necessary network modifications that I needed!

    1) Remote and Local use the same net, and both of them "home network".

    2) "Allow Unsecured Remote Access" = true in dsshost.config.exe

    3) http:/Localhost:<port>/security/Manager/Edit and set authentication to disable  (when you do this, you can see a Security Alert! in red when you run the node.)

    4) Disable the firewall for home network. I mean, go to ControlPane->Network->Firewall configuration->HomeNetwork->Disable

    And for me, following all this steps, and the tutorial 7 to change the code, deploying the services,  distribute them, start the nodes of the remote services and finally run the local service(the main) , I achieved it!!

    I hope this will be helpful for other people, because I wasted a lot of time, untill I've discovered what I had to do.

    Regards.

    • Marked as answer by Crispulina Thursday, May 30, 2013 11:10 AM
    Thursday, May 30, 2013 6:53 AM

All replies

  • This could be a lot of things. Is there any information in the DSS debug logs ?

    Honestly, I've had trouble getting manifest-driven multiple nodes to communicate. I resort to setting the nodes up in code. Hey - I'm not proud of it, but I can't get my manifests to work !

    When I've had errors like this, I discovered that my DSSHost program wasn't configured correctly. Please review this article

    http://msdn.microsoft.com/en-us/library/bb483066.aspx

    and read the section "Allow Unsecured Remote Access". It may be a factor.

    • Proposed as answer by CogswellCogs Thursday, May 30, 2013 2:08 AM
    Thursday, May 30, 2013 2:08 AM
  • thanks for the answer! but finally yesterday I achieved to run it in different PCs! I'm going to explain the necessary network modifications that I needed!

    1) Remote and Local use the same net, and both of them "home network".

    2) "Allow Unsecured Remote Access" = true in dsshost.config.exe

    3) http:/Localhost:<port>/security/Manager/Edit and set authentication to disable  (when you do this, you can see a Security Alert! in red when you run the node.)

    4) Disable the firewall for home network. I mean, go to ControlPane->Network->Firewall configuration->HomeNetwork->Disable

    And for me, following all this steps, and the tutorial 7 to change the code, deploying the services,  distribute them, start the nodes of the remote services and finally run the local service(the main) , I achieved it!!

    I hope this will be helpful for other people, because I wasted a lot of time, untill I've discovered what I had to do.

    Regards.

    • Marked as answer by Crispulina Thursday, May 30, 2013 11:10 AM
    Thursday, May 30, 2013 6:53 AM