locked
Warning: Some Unicode characters in this file could not be saved RRS feed

  • Question

  • User-1793215261 posted

    Hello

    A dialogue-box pops up when I use the following in my CSS:

    #content li::before {
        color: #05c6fc;
        content: "¦";
        padding: 15px;
    }

    The message says:

    myCss

    Some Unicode characters in this file could not be saved in the current codepage. Do yu want to resave this file as Unicode in order to maintain your data?

    I am guessing it refers to the coloured blue box that appears after 'content' in the code above. Should I click ' yes' to the pop-up message? I wish to keep the blue box in the list of items that appears on the page.

    Thanks for any guidance.

    Tuesday, April 16, 2019 11:11 AM

Answers

  • User839733648 posted

    Hi Bluenose,

    When I click on the 'Save with other encoding' button, I can select 'Unicode (UTF-8 with signature) Codepage 65001'. Is that what I should choose?

    Yes, I think that you could try to choose that and check if the code works.

    I've tried on my side and see that "Unicode (UTF-8 with signature) Codepage 65001" always the default selection.

    After selecting that, the css file will work ,too.

    Best Regards,

    Jenifer

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Thursday, April 18, 2019 6:03 AM

All replies

  • User839733648 posted

    Hi Bluenose,

    Some Unicode characters in this file could not be saved in the current codepage.

    This error generally occurs when a file contains characters that can only be saved by applying a Unicode code page.

    You could try the following steps:

    1. Click Cancel, and then choose Save As on the File menu.
    2. From the Save drop-down list, choose Save with Encoding.
    3. In the Advanced Save Options dialog choose, the encoding appropriate for your file.

    Reference: https://msdn.microsoft.com/en-us/library/1b19y3s9(v=vs.71).aspx

    Best Regards,

    Jenifer

    Wednesday, April 17, 2019 2:14 AM
  • User-1793215261 posted

    Thanks, Jennifer, for your reply.

    When I click on the 'Save with other encoding' button, I can select 'Unicode (UTF-8 with signature) Codepage 65001'. Is that what I should choose? At the top of my Site.master file, I have  <meta charset="utf-8" />

    Thank you.

    Wednesday, April 17, 2019 11:17 AM
  • User839733648 posted

    Hi Bluenose,

    When I click on the 'Save with other encoding' button, I can select 'Unicode (UTF-8 with signature) Codepage 65001'. Is that what I should choose?

    Yes, I think that you could try to choose that and check if the code works.

    I've tried on my side and see that "Unicode (UTF-8 with signature) Codepage 65001" always the default selection.

    After selecting that, the css file will work ,too.

    Best Regards,

    Jenifer

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Thursday, April 18, 2019 6:03 AM
  • User-1793215261 posted

    Many thanks, Jennifer!

    Thursday, April 18, 2019 1:01 PM