locked
Unable to make changes to Managed Backups in SQL Server 2016 RRS feed

  • Question

  • Hi

    I have a SQL Server 2016 instance in Azure with managed backups enabled. After following the guide (https://docs.microsoft.com/en-us/sql/relational-databases/backup-restore/enable-sql-server-managed-backup-to-microsoft-azure?view=sql-server-2016) I managed to get it working (after a few attempts).

    Since then I have tried to follow the guide on another SQL 2016 instance and I get the following error

    Msg 45207, Level 17, State 17, Procedure sp_add_task_command, Line 102 [Batch Start Line 3]
    The operation failed because of an internal error. Value cannot be null.
    Parameter name: sasToken Please retry later. 
        at Microsoft.WindowsAzure.Storage.Auth.StorageCredentials..ctor(String sasToken)
       at Microsoft.SqlServer.SmartAdmin.SmartBackupAgent.FileService.VerifyContainerURL(String containerURL, SqlConnection conn)
       at Microsoft.SqlServer.SmartAdmin.SmartBackupAgent.SmartBackup.ConfigureDbOrInstance(SmartBackupConfigParameters config, LogBaseService jobLogger, SqlConnection conn)
    

    On the server where it is working it is only configured to be enabled on some of the databases. I have tried to manually add the databases using msdb.managed_backup.sp_backup_config_basic but this also errors with the same message.

    Finally I tried to abandon managed backups by just running 

    EXECUTE msdb.managed_backup.sp_backup_config_basic NULL, 0, NULL, NULL

    But this also errors with the same message. I now have managed backups backing up half of the databases. Without reinstalling SQL, is there a way to fix this?

    I know I am not the only person with these errors...

    https://feedback.azure.com/forums/908035-sql-server/suggestions/32901835-unable-to-setup-managed-backup-on-sql-2016-using-a

    https://social.msdn.microsoft.com/Forums/sqlserver/en-US/1fa124f9-0eb5-49bb-be05-e0f96009518a/managed-backups-to-azure-cryptdecrypt-errors-in-log?forum=sqldisasterrecovery

    Thanks

    Sam

    Wednesday, September 5, 2018 8:52 AM

Answers

  • Thanks Moshin

    Just tried it and still the same error.

    • Marked as answer by SG_87 Wednesday, October 30, 2019 9:42 AM
    Monday, September 10, 2018 11:45 AM

All replies